Official GIGABYTE Forum

GA-970A-DS3P motherboard usb 3.0 ports not working

GA-970A-DS3P motherboard usb 3.0 ports not working
« on: November 16, 2014, 02:57:59 am »
Hi,

Like the title says, USB 3.0 ports are not working, The two at the back of the mobo and the headers on my case.
I have already tried installing the USB 3 driver that gigabyte has on its website for my mobo but when I try to install, it says that it cannot find supported hardware.
Can anyone help me with this issue? If you need any other info, please let me know.

Thanks

dmdilks

  • 2899
  • 34
  • "If it isn't broke don't fix it"
    • http://dmdcomputerservice.webs.com/
Re: GA-970A-DS3P motherboard usb 3.0 ports not working
« Reply #1 on: November 16, 2014, 03:27:54 am »
Did you check the Bios to make sure they are enabled?
GIGABYTE-GA-GA-X99-UD4 i7-5820K 3.30GHz, ADATA XPG Z1 32GB DDR4 2400 Quad, HIS R9 290X IceQ X2 4GB, In Win Glacier 900W, Cooler Master HAF 932, 2-240GB SSD sata-3, Win7 Ult-64bit 39" LED TV

Re: GA-970A-DS3P motherboard usb 3.0 ports not working
« Reply #2 on: November 16, 2014, 04:03:59 am »
Did you check the Bios to make sure they are enabled?

Yes I have alredy made sure its enabled

autotech

  • 1532
  • 35
Re: GA-970A-DS3P motherboard usb 3.0 ports not working
« Reply #3 on: November 18, 2014, 01:32:41 am »
Do they not work at all or just with USB3 devices. If they don't work at all time to RMA the board if they work with USB2 devices then I have seen problems with the USB3 drivers.
GA-Z170X-UD5,Core i5-6600K,16 GIG,3200 ram ,2 X Corsair 240GB SATA III SSD, 500 gig HD,7 ult 64\, Rx-480 8gig\

Z97X-SOC GIGABYTE, I5 4670k, 16 gig 1600 ram, 240 gig sata3 SSD,1x 500HD/ R9 280x, corsair 650 RM PSU

GA-Z97X-Gaming G1,850 corsair,,DDR4 3200,240SSd,6950 video,850EVA

Re: GA-970A-DS3P motherboard usb 3.0 ports not working
« Reply #4 on: November 18, 2014, 01:05:10 pm »
Do they not work at all or just with USB3 devices. If they don't work at all time to RMA the board if they work with USB2 devices then I have seen problems with the USB3 drivers.

They are not working for any type of USB device, even the 2.0 ones. The thing is, when I put my USB stick in it, the stick lights up for like 2 seconds before it goes out but does not get detected at all. It leads me to believe that power is getting to the ports fine...

dmdilks

  • 2899
  • 34
  • "If it isn't broke don't fix it"
    • http://dmdcomputerservice.webs.com/
Re: GA-970A-DS3P motherboard usb 3.0 ports not working
« Reply #5 on: November 18, 2014, 03:01:58 pm »
Have you tried to disconnect the front ports to see if they work on the back.
GIGABYTE-GA-GA-X99-UD4 i7-5820K 3.30GHz, ADATA XPG Z1 32GB DDR4 2400 Quad, HIS R9 290X IceQ X2 4GB, In Win Glacier 900W, Cooler Master HAF 932, 2-240GB SSD sata-3, Win7 Ult-64bit 39" LED TV

Re: GA-970A-DS3P motherboard usb 3.0 ports not working
« Reply #6 on: November 18, 2014, 06:13:28 pm »
Have you tried to disconnect the front ports to see if they work on the back.

I can try that tonight and let you know...
BTW thanks for the replies guys!

autotech

  • 1532
  • 35
Re: GA-970A-DS3P motherboard usb 3.0 ports not working
« Reply #7 on: November 19, 2014, 01:29:40 am »
Not a problem is why we are all here. Most times I learn more than I help.  I am sure you have tried more than one USB device.  If you have ports that don't read multiple devices then that narrows it down to the ports. 
GA-Z170X-UD5,Core i5-6600K,16 GIG,3200 ram ,2 X Corsair 240GB SATA III SSD, 500 gig HD,7 ult 64\, Rx-480 8gig\

Z97X-SOC GIGABYTE, I5 4670k, 16 gig 1600 ram, 240 gig sata3 SSD,1x 500HD/ R9 280x, corsair 650 RM PSU

GA-Z97X-Gaming G1,850 corsair,,DDR4 3200,240SSd,6950 video,850EVA

dmdilks

  • 2899
  • 34
  • "If it isn't broke don't fix it"
    • http://dmdcomputerservice.webs.com/
Re: GA-970A-DS3P motherboard usb 3.0 ports not working
« Reply #8 on: November 19, 2014, 04:02:21 am »
I have been doing this for over 30 yrs and you always will learn something every day.
GIGABYTE-GA-GA-X99-UD4 i7-5820K 3.30GHz, ADATA XPG Z1 32GB DDR4 2400 Quad, HIS R9 290X IceQ X2 4GB, In Win Glacier 900W, Cooler Master HAF 932, 2-240GB SSD sata-3, Win7 Ult-64bit 39" LED TV

Re: GA-970A-DS3P motherboard usb 3.0 ports not working
« Reply #9 on: November 19, 2014, 01:35:19 pm »
Hey guys,

So I tried what dmdliks suggested and removed the USB 3.0 header from the mobo but doing so did not cause the the USB 3 ports at the back to gain functionality. I tried with 3 different types of devices, Pen drive, Headset, USB cable.
And as expected, the ports at the back made the pen drive light up for a second, as if it powers up but nothing after that. And the front case ports just didn't receive power.
I honestly don't know what could go wrong other than driver issues. It was working perfectly until I re imaged the computer. I might try to do that again as I don't have anything important on the computer (everything is still backed up).
Will update you guys when it is done.

Thanks,
Daniyal

autotech

  • 1532
  • 35
Re: GA-970A-DS3P motherboard usb 3.0 ports not working
« Reply #10 on: November 20, 2014, 01:49:11 am »
Fresh install might work better. I didn't know you imaged it. Images are life savers but sometimes a fresh install does wonders
GA-Z170X-UD5,Core i5-6600K,16 GIG,3200 ram ,2 X Corsair 240GB SATA III SSD, 500 gig HD,7 ult 64\, Rx-480 8gig\

Z97X-SOC GIGABYTE, I5 4670k, 16 gig 1600 ram, 240 gig sata3 SSD,1x 500HD/ R9 280x, corsair 650 RM PSU

GA-Z97X-Gaming G1,850 corsair,,DDR4 3200,240SSd,6950 video,850EVA

AgentFXA

  • 309
  • 6
Re: GA-970A-DS3P motherboard usb 3.0 ports not working
« Reply #11 on: November 24, 2014, 08:21:31 am »
Had recently the same problem with the disappearing Via USB3 controller - power the system down then after the bootup the Via controller is back and the driver can be installed. Just make sure you install the latest 4.70 via driver which seems to fix the vanishing usb3 ports issue.

GA-990FXA-UD3v4.0 / FX-8320 / GV-RX570AORUS-4GD / 24GB HyperX Fury 1866  / SeaSonic 650W / Thermaltake Armor MX / Win7x64