Official GIGABYTE Forum

Windows 10 drivers - GA-Z68X-UD5-B3

Daf

  • 18
  • 0
Windows 10 drivers - GA-Z68X-UD5-B3
« on: August 03, 2016, 09:42:49 am »
Updated to Windows 10 (from 7) just in time before the free update time expired.

The Download page has a distinct lack of drivers for the Mobo for Windows 10
http://www.gigabyte.com/products/product-page.aspx?pid=3848#driver

Just
- Intel Management Engine Interface (11.0.0.1158 - 2015/09/17)
- Intel INF installation (10.1.1.8 - 2015/07/07)

No LAN, USB, Storage etc

Is it just because Gigabyte have stopped supporting it ?

LAN had issues - but managed to fix it by manually entering IP, Gateway, Subnet and DNS

USB3 still seems to have issues.
Doesn't see my USB3 connectors as USB 3.
Tried to install a more recent chipset driver direct from Intel - but this made my card reader stop appearing - so went back.

Regularly get "This device can perform faster on USB 3" type message when I plug in an external USB3 drive, using USB3 cable, into the blue USB3 port.
BUT sometimes do get USB3 speeds ~ 100-150MB/s - so guess could live with it.


For Windows 7 64 - the GIgabyte drivers page lists : Renesas(NEC) USB 3.0 Driver (2.0.30.0)

Is it possible to get this for Windows 10 from somewhere ?

Re: Windows 10 drivers - GA-Z68X-UD5-B3
« Reply #1 on: August 03, 2016, 11:59:49 am »
Hello,

Does your boards BIOS (latest?) have an option to enable XHCI mode for the USB controller?
CPU: Intel i7-6700K | MOBO: MSI Z170A Krait Gaming | RAM: Corsair LPX 32GB 3200 DDR4 | GFX: Gigabyte GTX 970
CASE: Zalman Z11 | FC: Zalman MFC1-Plus | HS: Zalman FX70 | PSU: Coolermaster V850 Gold
SSD: Hynix 256GB | HDD: WD Blue 1TB x2 | ODD: Sony DVDRW | RMD: SoftPerfect 6GB | OS: Win10

Daf

  • 18
  • 0
Re: Windows 10 drivers - GA-Z68X-UD5-B3
« Reply #2 on: August 03, 2016, 11:39:54 pm »
Hmm - I do have the latest FIrmware (F10)

I didn't have a XHCI setting - but did have a USB 3.0 Turbo setting that was Disabled.

Enabled this, then the USB3 card reader (empty) drives showed up!

BUT then my external USB 3 drive would only copy at ~20-30MB/s

Re-installed the chipset drivers - no change.

Installed the USB 3 drivers listed on Gigabyte for Windows 7-64 - and the external drive works at speed again :)
BUT the USB card reader now doesn't show up.......

Daf

  • 18
  • 0
Re: Windows 10 drivers - GA-Z68X-UD5-B3
« Reply #3 on: August 04, 2016, 09:36:02 am »
Hmm - it seems the card reader is working - just changed the way it behaves a bit.

Rather than showing all the empty drives - they only show up when a card is inserted.

Still getting messages about performing better if plugged into USB 3 port, even though items are.