Official GIGABYTE Forum

GA-Z87X-OC Force USB problem

Toms200

  • 4
  • 0
  • I'm spiritual advancing my self.
GA-Z87X-OC Force USB problem
« on: January 01, 2017, 09:10:17 pm »
Hi. Microsoft messed up USB driver (2.0 and 3.0). The transfer speeds are cut off and no solution is available on the internet. As much as I have seen hundreds of users are having speed issue on all motherboards not just gigabyte. It would be nice if Gigabyte could make their own driver. Microsoft is failing people.
Thank you!
I'm mentalist, sometimes pastor because seems like people trust me and I have what it takes to be one of them.
Like to push mind and understanding  futher than people already know.
Free from most of the complexes, positive person however i can be an A-Hole when I'm in bad mood.

Toms200

  • 4
  • 0
  • I'm spiritual advancing my self.
Re: GA-Z87X-OC Force USB problem
« Reply #1 on: January 09, 2017, 09:46:31 pm »
I was wondering if anybody is taking things seriously or this is just to cheat the minds of the people? Don't wan't to swap parts for other brand because nobody cares.
I'm mentalist, sometimes pastor because seems like people trust me and I have what it takes to be one of them.
Like to push mind and understanding  futher than people already know.
Free from most of the complexes, positive person however i can be an A-Hole when I'm in bad mood.

Toms200

  • 4
  • 0
  • I'm spiritual advancing my self.
Re: GA-Z87X-OC Force USB problem
« Reply #2 on: January 27, 2017, 07:52:48 pm »
So I'm chatting by my self....alone
I ditched Win10 and installed Win7 Ultimate and everything runs smoothly. Got back transfer speeds from 3-7mbs to 190mbs. All what was wrong was the joke called win10.
I'm mentalist, sometimes pastor because seems like people trust me and I have what it takes to be one of them.
Like to push mind and understanding  futher than people already know.
Free from most of the complexes, positive person however i can be an A-Hole when I'm in bad mood.

 

anything