Official GIGABYTE Forum

GA-970A-DS3P rev 2.0 not allowing me to do ANYTHING

GA-970A-DS3P rev 2.0 not allowing me to do ANYTHING
« on: February 12, 2017, 08:23:10 am »
i bought a desktop for christmas last year an these are its specs

GA-970A-DS3P motherboard (started with bios vers fc)
16gb 1600 value ram
xfx rx 480 8gb gpu
fx 8300 black edition

the issue im having is i SHOULD be able to OC even a little bit but the mobo seems to be locked on eveything you want to do..even though ive watched 30 vids on youtube of people clickin this an that on this mobo.. but mine just wont do it for some reason the best i can do with it is disable all the energy saving stuff.... it said it was 3.6 for the longets time but the 8300 is 3.3.... the oc software easytune NEVER seemed to work... an autotune was always darkened so i cant use it at all... one minute it says its at 3.8 then i turn it on next day it stays at 3.4  day after it stays at 3.6 an i dont do anything really but play games an surf the web... same routine everyday... so i updated the bios to FD an things just got worse... now it doesnt even say FX 8300 black edition in gigabytes sys info.. ram says 800 an not 1600 sys fan 2 an pwr fan have vanished in the gigabytes fan app.... an it says  the 8300 is topped at 3.65 but has never goes past 3.58.... gigabytes bios info says FD... its system info says FC an the windows sys info says 1gb gpu... the mobo alone wont let me do anything an i feel ripped off an frustrated like crazy... an thats just the start .... can anyone help with this... just trying to figure out  how to oc or drop things down a bit an get  stuff back to before maybe even working right as it seems to not even have done that from start

 

anything