Official GIGABYTE Forum

GV-N460OC-1GI Low GPU Usage under Battlefield: Bad Company 2.

C++vid

  • 6
  • 0
GV-N460OC-1GI Low GPU Usage under Battlefield: Bad Company 2.
« on: September 17, 2010, 07:45:27 pm »
So It's been ~1 month or so that I've had this card on my rig now, and I've noticed that it underachieves, big time, under Battlefield: Bad Company 2.

Very so-so gameplay (40-60 FPS) when running in DX11 mode. Stuttering very noticeable.

Specs:

AMD Phenom II X4 955 BE @ Stock speed
ASUS M4A89GTD PRO/USB3 (1456 Bios)
4GB (2x2GB) Corsair XMS3 DDR3 @ 1333MHz
Thermaltake TRX-750M 750W Modular PSU (single +12V Rail)
Windows 7 x64 Home Premium
NVIDIA ForceWare 260.63 Beta.

So what could be causing this so-so performance under this game?, shouldn't I be getting better performance?

One thing I've noticed is that the GPU usage never goes above the high 60s (using both GPU-Z and MSI Afterburner).

Settings:

1600 x 900, all details set to HIGH, AA @ x2, AF @ x16, Vsync OFF in-game (but set to on using D3DOverrider, Triple Buffering set to on as well), HBAO OFF.

Any advice?

Thanks.

EDIT: Stock BIOS on GV-N460OC-1GI.
« Last Edit: September 17, 2010, 07:47:46 pm by C++vid »

Dark Mantis

  • *
  • 18413
  • 413
  • 10typesofpeopleoneswhoknow binaryandoneswhodont
    • Dark Mantis
Re: GV-N460OC-1GI Low GPU Usage under Battlefield: Bad Company 2.
« Reply #1 on: September 17, 2010, 07:52:49 pm »
Is it just this game? If so I would check and see if the game's website has any patches. If no have you updated your BIOS to the latest version and using the lastest drivers?

The other thing to check, as I notice that yuou said it wass stuttering , is the latency on your machine. Download andrun dpclatency checker from:
http://www.thesycon.de/deu/latency_check.shtml
Run this and then post back with the results.
Gigabyte X58A-UD7
i7 920
Dominators 1600 x6 12GB
6970 2GB
HX850
256GB SSD, Sam 1TB, WDB320GB
Blu-Ray
HAF 932

Gigabyte Z68X-UD5-B3
i7 3770K
Vengeance 1600 16GB
6950 2GB
HCP1200W
Revo Drive x2, 1.5TB WDB RAID0
16x DLRW
StrikeX S7
Full water cooling
3 x 27" Iiy

C++vid

  • 6
  • 0
Re: GV-N460OC-1GI Low GPU Usage under Battlefield: Bad Company 2.
« Reply #2 on: September 17, 2010, 11:06:38 pm »
Is it just this game? If so I would check and see if the game's website has any patches. If no have you updated your BIOS to the latest version and using the lastest drivers?

The other thing to check, as I notice that yuou said it wass stuttering , is the latency on your machine. Download andrun dpclatency checker from:
http://www.thesycon.de/deu/latency_check.shtml
Run this and then post back with the results.
Game's patched to the latest version (I own the steam version, so the game is kept up to date automatically).

Latest BIOS and drivers (chipset, sound, video and even onboard lan) all installed.

DPC latency is rock solid under these drivers (260.63), so I don't think that's the issue here to be quite honest (even when I had DPC latency issues [back when I had 258.96 installed] it was rock solid WHEN running BFBC2).

Thanks for the reply btw.

Dark Mantis

  • *
  • 18413
  • 413
  • 10typesofpeopleoneswhoknow binaryandoneswhodont
    • Dark Mantis
Re: GV-N460OC-1GI Low GPU Usage under Battlefield: Bad Company 2.
« Reply #3 on: September 17, 2010, 11:13:08 pm »
Quote
DPC latency is rock solid under these drivers (260.63), so I don't think that's the issue here to be quite honest (even when I had DPC latency issues [back when I had 258.96 installed] it was rock solid WHEN running BFBC2).

Have you actually run the progream to check or are you just summising?

Also there is a new beta driver for your GPU just come out yesterday. Whether it will help you I don't know.
Gigabyte X58A-UD7
i7 920
Dominators 1600 x6 12GB
6970 2GB
HX850
256GB SSD, Sam 1TB, WDB320GB
Blu-Ray
HAF 932

Gigabyte Z68X-UD5-B3
i7 3770K
Vengeance 1600 16GB
6950 2GB
HCP1200W
Revo Drive x2, 1.5TB WDB RAID0
16x DLRW
StrikeX S7
Full water cooling
3 x 27" Iiy

C++vid

  • 6
  • 0
Re: GV-N460OC-1GI Low GPU Usage under Battlefield: Bad Company 2.
« Reply #4 on: September 18, 2010, 12:22:03 am »
Quote
DPC latency is rock solid under these drivers (260.63), so I don't think that's the issue here to be quite honest (even when I had DPC latency issues [back when I had 258.96 installed] it was rock solid WHEN running BFBC2).

Have you actually run the progream to check or are you just summising?

Also there is a new beta driver for your GPU just come out yesterday. Whether it will help you I don't know.

Yup.

Quote
DPC latency is rock solid under these drivers (260.63)

What Beta driver are you talking about? 260.63? Cause that's what I'm running right now. Although I've got NVIDIA's version of the driver installed, not GIGABYTE's.
« Last Edit: September 18, 2010, 12:24:19 am by C++vid »

Dark Mantis

  • *
  • 18413
  • 413
  • 10typesofpeopleoneswhoknow binaryandoneswhodont
    • Dark Mantis
Re: GV-N460OC-1GI Low GPU Usage under Battlefield: Bad Company 2.
« Reply #5 on: September 18, 2010, 12:24:54 am »
Quote
What Beta driver are you talking about? 260.63?

To be honest I can't remember the actual number but I know it was only released yesterday so if that is the one you are using then yes.
« Last Edit: September 18, 2010, 12:28:05 am by Dark Mantis »
Gigabyte X58A-UD7
i7 920
Dominators 1600 x6 12GB
6970 2GB
HX850
256GB SSD, Sam 1TB, WDB320GB
Blu-Ray
HAF 932

Gigabyte Z68X-UD5-B3
i7 3770K
Vengeance 1600 16GB
6950 2GB
HCP1200W
Revo Drive x2, 1.5TB WDB RAID0
16x DLRW
StrikeX S7
Full water cooling
3 x 27" Iiy