Official GIGABYTE Forum

Questions about GIGABYTE products => Motherboards with AMD processors => Topic started by: Neroxide on July 17, 2014, 04:32:53 pm

Title: GIGABYTE GA-970A-DS3P Problems
Post by: Neroxide on July 17, 2014, 04:32:53 pm
I don´t even know where to start...
So, I bought the Gigabyte GA-970A-DS3P motherboard because I thought it would be good.
Until now, it´s been a complete hell.

So, let´s list a couple of the biggest problems I have with this! I would really appreciate it if you´ve got a solution for any of these.

1. In Windows 7 and 8, the motherboard just locks up the whole computer when you try to multitask. And it shouldn´t because there is an AMD-FX8350 in it with a SAPPHIRE R9-270X OC Dual Boost and a Seagate 2TB 7200RPM HDD.

2. In Windows 8, I get Blue Screen Of Deaths all over the bloody place! (No, I haven´t installed the s***ty On/Off Charger).

3. I can´t install Linux. Live system USBs crash and hang and it will not support USB 3.0 or 2.0 for that matter, EVEN with IOMMU on.
Title: Re: GIGABYTE GA-970A-DS3P Problems
Post by: autotech on July 18, 2014, 02:14:26 am
Did you do a fresh install of windows 7 and update it fully, Also install the amd chipset drivers ?
Title: Re: GIGABYTE GA-970A-DS3P Problems
Post by: Neroxide on July 18, 2014, 02:28:11 pm
Did you do a fresh install of windows 7 and update it fully, Also install the amd chipset drivers ?
Every driver is installed. The latest AMD drivers are installed, and all the other random stuff Gigabyte gives me (although I don't use any of their utilities. On/Off Charger completely screwed up my computer).

And yes, the computer completely locks up on Windows 7, Windows 8 and Vista. And Linux os'es won't even run. Whenever I try to install Ubuntu Gnome, Ubuntu, Linux Mint 17 or any other os until now via my usb, the usb will just crash.
Not to mention that if you try to run the Linux USB in a 2.0 port, it won't even bloody find the USB! Nope, only in the completely not working 3.0 ports, so I had to turn on IOMMU in the bios. And IOMMU turned on worked, at first. But eventually, it turned out that it didn't work. Every time the installer just hangs, like Gigabyte tries his hardest to let me not install Linux.

But the list of problems goes on; whenever I try to mount my Windows partition in a Linux environment; Gigabyte deletes all the partitions from my HDD. Yes, I've lost all my files 3 times already, because Gigabyte screwed me over. And it didn't even delete my partitions, oh no! It made a new partition and made it a RAW format! THAT'S FOR CD ROM DRIVES DAMNIT. And it's not the HDD itself, because I ran the Seagate Check and some other benchmarks. They both say that my Seagate is perfectly healthy, though my HDD is slowing down because Gigabyte is completely breaking it. Constantly.

I solved this problem by creating a new partition (''free space'') in Windows itself and THEN ran Linux, but still I was out of luck because the installer hangs every time. And it still says that the free space partition is ''read only'', probably thanks to the horrible USB hubs in the Gigabyte motherboard.

So I gave up on Linux; It's not like I wanted to have a choice of which OS I want to install... No, why would I?

And then the new BETA BIOS update came along! It said that it improved the ''usb compatibility''. So, completely happy, I installed the new beta BIOS. And it did nothing. Linux still doesn't work and my wifi constantly turns off.

Oh yes, that's another problem: I use a wireless usb adapter (the Linksys AE2500). But the usb hubs in the motherboard just craps all over the connection. In my left USB 3.0 port in the front, I've got a 2.0MBit/s connection. In the right I've got a 0.2Mbit/s connection. One of the USB 2.0 ports on the front is giving me 20Mbit/s. But one of the usb ports on the back gives me the full 50Mbit/s. The only problem being that this changes every time I boot up my computer! I've got horrible wifi thanks to this motherboard, and if I hit the 50Mbit/s, the USB hub can't handle it and completely SHUTS DOWN, leaving me with NO internet at all. Yes, this happens on Windows 7, 8 and Vista.

It also says it's ''AMD 8350FX Compatible'' which is the biggest lie known to mankind, as it detects it, yes, but it only uses 20% of it and just craps over the whole performance for no goddamn reason. And apparently my 8GB Ram is not compatible (although it runs well; it just says so on the site). Who the HELL in the right mind makes a motherboard not compatible with almost every sodding RAM?

And yes, I always install the drivers and yes, I always update Windows. I'm not one of those people who don't know what they are talking about :P
I've installed Windows 7 3 times now, and Windows 8 once (Windows vista also once) but the problems don't go away.
I messed with the BIOS settings but there just is no difference.

I hope someone, just SOMEONE, here has a fix for this horrible, terrible motherboard. The BIOS software is complete and total s***, the motherboard itself is completely crap, it misses almost every feature and the features that it has are half-assed and all poorly implemented. If there is no fix for this motherboard, which probably only exists out of greed, I will not hesitate to burn it down. And I will, because I have never been so pissed over a piece of technology as this mobo in my entire life. It pisses me off everyday I start up my computer and it fails to find the correct bloody settings to begin with.

If there's no fix, and according to the internet; there isn't, then I will burn it down and buy an ASUS mobo, as I should have done in the first place.
And apparently, GIGABYTE is doing this ever since their UDP motherboard! How great!

I'm sorry this became sort of like a rant, but as you can read, nothing works. NOTHING. And for what I want to do with my pc, and with the components I've bought (which it barely even handles -,-), I'm fed up with it, because it can't do what I want.
Title: Re: GIGABYTE GA-970A-DS3P Problems
Post by: autotech on July 18, 2014, 05:47:03 pm
Been there done that so i understand.  Myself i would try flashing bios back to what it was before problems started and take my hard drive to another computer hopefully running windows xp or if you have an old xp disk use that and do a long format.  I have found a windows 7 format leaves all kinds of dirt behind. Then try it from there. Make sure when you are installng it no usb drives or devices are plugged in unless you are installing windows from a usb drive.

You can do a search online and do a secure format of your hard drive if you dont have access to a xp puter or disk.
Title: Re: GIGABYTE GA-970A-DS3P Problems
Post by: Permethion on September 02, 2014, 01:12:04 pm
I had similar issues with a like configuration same board and graphics. different drive. Eventually I tracked it down to the graphics card causing all kiinds of issues. checked out and there are some known incompatability  between these two bits ok kit.  Cpu was maxing out constantly, fan being very irratic, system hanging and just p&*^ssing me off. I rolled back the card to an old nvidia card and all the issues miraculusly disapeared luckily before the hammer came out.   may not be the same issue but gives you another avenue to check out :) this was after I did the full driver and bios updates reinstalled windows 7 ultimate a few times to
Title: Re: GIGABYTE GA-970A-DS3P Problems
Post by: JGB123 on October 10, 2014, 04:48:59 am
And apparently my 8GB Ram is not compatible (although it runs well; it just says so on the site)

What's the RAM's make, model, speed and number of DIMMs? Is it 1.5V RAM? Which site?

I see that the GA-970A-DS3P's QVL makes no mention of the caution which is found in the QVLs of the various Gigabyte 990X/990FX 'boards; that 1866MHz or faster memory is limited to one DIMM per channel:

QVL 970A-DS3P.xls - mb_memory_ga-970a-ds3p.pdf

"Note: Only one DIMM per channel is supported for DDR3-1866MHz and higher speed as using an AM3+ CPU."

QVL 990FXA-UD3.xls - memory_ga-990fxa-ud3.pdf

Title: Re: GIGABYTE GA-970A-DS3P Problems
Post by: JGB123 on November 03, 2014, 05:01:58 am
"Here is my updated fix"

GIGABYTE GA-970A-DS3 motherboard not working with 64 bit kernel - Page 4
Title: Re: GIGABYTE GA-970A-DS3P Problems
Post by: Vizim on January 22, 2016, 09:28:18 pm
Hi, I have FX 8320E and GA-970A-DS3P with 8GB 1866 MHz RAM memory. I try few version of linux os, for example : Ubuntu, Gnome Ubuntu, Fedora, all latest... only 32 bit works fine, but when I use PAE to use all RAM memory my linux just hangs..., this same I see when I install 64 bit version of this OS.

All informaction about IOMMU don't help, when I use iommu=soft, i have litle bit long time to next hangs.

System just work fine, until frozen, after that I see everything on the screen but all process just stop.

I try to see log, some kernel messages, but nothing.

Is somebody have this same problem like me ? (Sorry for my english)
Title: Re: GIGABYTE GA-970A-DS3P Problems
Post by: mike_ironfist on March 15, 2017, 11:12:41 am
Hi friends! I've got an improved solution! Hopefully this will fix the problems for most of you.
The "soft" IOMMU option is actually bad because it doesn't allow you to use IOMMU for VMs.


1. Enable IOMMU in BIOS/EFI settings.

2. Boot your Linux system normally and then open a terminal and edit /etc/default/grub. I usually use nano to edit system config files.
Code: [Select]
sudo nano /etc/default/grub
Find the line that says this:
Code: [Select]
Change it so that is says this:
Code: [Select]
GRUB_CMDLINE_LINUX="amd_iommu=on iommu=pt"
3. Finally, update GRUB and reboot.
Code: [Select]
sudo update-grub && sudo reboot
4. All done! All of your USB 3.0 and 2.0 ports will work, your ethernet will work AND you will be able to use IOMMU features for GPU passthroughs on virtual machines. This also fixes the slow boot times.