Official GIGABYTE Forum

z77x-up4-th- doesn't start


  • 1
  • 0
z77x-up4-th- doesn't start
« on: December 29, 2012, 06:13:17 pm »
HI all

It's the first time I have a problem assembling a brand new pc......I bought a Gigabyte z77x-up4-th (my first gigabyte motherboard ever)  and it looked great but.....I bought a Intel 3770k CPU and Kingston 4gb memory and after I assembled  all pieces carefully (avoiding static, using an insulation working with mb and so on) I tried to start the new pc but it didn't start. Or better it started (all fans moving, power button ok....) but after few seconds it stops, to restart again after other few seconds...and to stop again after other few seconds and so on in an endless loop, broken using PSU main switch. I tested all components (memory OK in 2 PCs, CPU worked on a ASUS motherboard, graphic card works) and I'm thinking the issue  could  be:

- Motherboard is broken. How can I test it ? I don't see any  LED on mb to check if the power is OK, like in ASUS
- There are some known incompatibilities among z77x-up4-th and some PSUs: I've an old 650 PSU (no Corsair) and a brand new Corsair 800 and both don't work  but I think it's not PSU the problem.
- As my CPU is 3770k (Ivy Bridge)  it could happen BIOS isn't updated for that CPU. But how can I update BIOS in a non-working motherboard ???

So this is my problem...any hint will be greatly appreciated.


Re: z77x-up4-th- doesn't start
« Reply #1 on: January 08, 2013, 12:18:03 pm »
Hello mocion and others.
Have you found a solution?
I feel the same.
I assembled everything with the utmost care in a system (2500k + Seasonic X-760) that is 6 months old and has always worked perfectly (on a Asus MB).
When upgrading the motherboard GA-z77x UP4-TH-I find the problem that will not start.
The motherboard enters a loop where it reboots every ten seconds over twenty emits short beeps.
I've tried everything (disconnect gpu, ram, hd, ssd, ...). It is impossible to update bios here.
I probably tramitaré an RMA and try to change the motherboard model.
« Last Edit: January 08, 2013, 12:19:14 pm by Roblock »

Re: z77x-up4-th- doesn't start
« Reply #2 on: January 08, 2013, 11:10:35 pm »
I've solved. Turns eps 4 +4 cable is not compatible with this motherboard.

Finally there was a happy ending