Official GIGABYTE Forum

GA-Z77X-UD3H VIA USB 3.0 stopped working

GA-Z77X-UD3H VIA USB 3.0 stopped working
« on: January 02, 2013, 07:48:24 am »
New build, Win 7 Pro 64-bit, i5-3570K, 8GB RAM

I was very happy on first install, having noticed the warning about which USB ports to use first prior to driver installation, so I had no trouble getting everything installed & working initially - that was back in July I believe.  These devices were typically connected to the USB ports on the back panel and working flawlessly:
Intel USB 3.0 (under the LAN): Microsoft keyboard, Raptor mouse
VIA USB 3.0 (above the eSATA ports): Buffalo External HDD (3.0 capable), Microsoft Webcam
VIA USB 3.0 (far "left" under the PS/2): Belkin Speedpad and Logitech joystick

Yesterday or the day before I noticed that the External HDD wasn't recognized anymore, and none of the other devices on the other 3 VIA ports were working either.  Connecting the External HDD to a USB 2.0 port from a motherboard header to my case top panel recognized the drive (though I got the message about "could perform faster").  Nothing I've done so far has resulted in those 4 VIA USB ports to be usable again, though they were just fine for months.  I didn't make any changes on purpose, but I cannot guarantee whether or not a Windows update came through and resulted in the problem and I just didn't notice it for a day or two - completely possible, though unlikely I believe (I use that External HDD very frequently).

I've tried downloading and reinstalling the VIA USB drivers from the Gigabyte website (version 6.1.7600.1902 dated 7 August), but when I try to run SETUP.EXE from the VIAUSB3 folder after extracting, I am told that the hardware isn't there (see attachment).  Sure enough, Device Manager has no listing for the VIA host controller (see attachment).  I do see a folder in C:\ called VIA_XHCI but there's only two files there, Language.ini and usb3monitor.exe, and the latter tells me that it's already started if I try to run it.

I've updated from F7 to F11 in the hopes that it would re-detect the controller (as seems to have been the case for others around the web) but no joy.

I've looked around in the BIOS and in the manual for the enable/disable switch for the VIA USB ports, but can't seem to find it if it exists.

I have the F16, F17, and F18 BIOS as well but haven't tried flashing them yet - certainly willing to try everything.

I also have the drivers direct from but haven't tried installing them yet, I prefer to use motherboard-manufacturer-specific drivers whenever possible.

Any other thoughts?  Anyone know where the enable/disable switch is in the BIOS?


Re: GA-Z77X-UD3H VIA USB 3.0 stopped working [SOLVED]
« Reply #1 on: January 02, 2013, 07:10:22 pm »
Can't find a button to edit the OP so...

This morning I took these steps to continue troubleshooting:
- Loaded defaults from within BIOS - problem still exists
- Flashed to the F16 BIOS - problem still exists
- Loaded defaults again - problem still exists
- Opened case and pressed the Clear CMOS button AND connected the Clear CMOS jumper, then loaded defaults when the BIOS started back up - like magic, the VIA Host Controller was back in Device Manager.  Installed the drivers, and we're back in business on all four USB ports, in USB 3.0 mode.

Not sure if that solution will work for everyone, but it worked for me.  Now I'll just have to remember that in case it happens again.