Official GIGABYTE Forum

GA M56S S3 - No power

GA M56S S3 - No power
« on: November 17, 2008, 06:28:49 pm »
Hi, I just ordered these parts ..

Motherboard: GA-M56S-S3
CPU: AMD Athlon 64 X2 4850e 2.5GHz Socket AM2 Energy Efficient 1MB L2 Cache Retail Boxed Processor
GFX: Sapphire HD 3650 512MB GDDR3 Dual DVI TV Out PCI-E Graphics Card
RAM: Extra Value 1GB DDR2 667MHz PC5300 240pin Extra Value Ram

I installed the hardware and tried to turn it on, nothing happens at all, no sounds and no fans turning.

I have a 450watt power supply and all the cables are attached in the correct places, it's a 12 pin power connection and the square power connection is connected.

I am stuck with what the problem can be and thought I'd try and get some advice before spending more money at a shop to get it fixed, thanks.

Re: GA M56S S3 - No power
« Reply #1 on: November 17, 2008, 07:44:52 pm »
Sorry, I forgot to add that I bought a new PSU unit, 450 watt, I have tried my old one and that didn't work either.


  • *
  • 1328
  • 57
  • Admin
Re: GA-M56S-S3 - No power
« Reply #2 on: November 19, 2008, 10:26:10 am »

first try clear CMOS by shorting for a few seconds pins of CLR_CMOS.

please mind to support this CPU you need bios version F4G, you can check here:
so maybe on your MB there is older bios than F4G and that's the reason of the problem. So to upgrade you will need the CPU which is supported by previous BIOS versions, just to boot the MB and run BIOS upgrade, then switch to your 4850e CPU.

if still no help even after BIOS upgrade then disconnect vga, hdd, optical drive, memory from MB, just leave only CPU and PSU. then check if there is any sound from speaker connected to F_PANEL pin header when power switch on. if no sound it maybe failure of PSU / MB / CPU, then you will need to exchange each one of these 3 components to find out which one is damaged.
ZX-S & C64 are still my favourites ;-)