Official GIGABYTE Forum

790FXTA-UD5 and LSI 3041E


  • 2
  • 0
790FXTA-UD5 and LSI 3041E
« on: January 31, 2010, 12:53:38 am »
I've just bought 790FXTA-UD5 to upgrade my old motherboard, MSI K9A2 Platinum. The problem is I cannot use my LSI 3041E raid card ( which is a 4X card ). I have 2 4890 graphic cards. So I am using them on first and second PCI-e 16X slots and LSI 3041E on the third. But the computer halts after LSI bios detects the disks, I cannot even enter the bios while the 3041E is inserted.

AFAIK most 790FX chipset boards utilize 32 PCI-e lanes for PCI-e 16X slots, so normally the configuration is 16X-16X, or 8X-8X-8X-8X. I was using the 3041E on the MSI by setting the lanes to 8x-8X rather than 16X-16X, so my configuration was 8X-8X-4X-EMPTY. So perhaps the problem is both 4890s uses 16X so the configuration is set to 16x-16X where in fact the third slot is not empty.  But I  did not see any settings on the bios ( F1 ) to set the PCI-e lanes. There is only a setting for the display initialization sequence.

Perhaps the slots are intended to graphic cards only. If so it must be restricted from the bios rather than on 790FX chip I think, because I can use the raid card on a graphic card slot on my previous mobo. Has anyone tried and/or succeeded to operate a non-graphical pci-e card on the third slot? If anyone has I'll appreciate to guide me for the settings. Also, I'm open to any advices. I've already tried disabling on-board SATA3 and e-SATA controllers.

By the way here is my system specs :

AMD Phenom II 965BE C3
2x2GB Patriot DDR3-1600Mhz CL7 sticks
2x4890 1GB on CF
2xFujitsu MBA3073RC SAS drives as Raid 0 ( yet unoperational because of unoperational LSI 3041E )
2xSamsung 1Tb drives on SB750
Xilience 1000W PSU

Best regards,


  • 2
  • 0
Re: 790FXTA-UD5 and LSI 3041E
« Reply #1 on: January 31, 2010, 12:21:43 pm »

I've managed the 3041E work. It turned out o be a boot problem. I set the interrupt 19 hook to off and removed the bios boot support on the LSI, then the whole system worked. Now the lanes are coonfigured as 16X ( 1st 4890 ), 8X ( 2nd 4890 ) and 4X ( 3041E ).

I even turned off the onboard SATA3 and E-SATA, no problems. Now the only problem I have is being unable to boot from the disks connected to LSI.
The problem persists if I turn the boot support on ( as far as I see int 19 hook has no effect ).

So, any ideas on not being able to boot from the 3041E?