Official GIGABYTE Forum

Gigabyte HD 7950 on Intel DX58SO !!

Gigabyte HD 7950 on Intel DX58SO !!
« on: June 02, 2013, 09:30:41 pm »
hi guys,

I recently got this Gigabyte HD 7950. When i installed it my system, it didn't go beyond the splash screen (boot sequence 5A). I thought the psu that am using was not enough (CX500), so i got a bigger one (GS700). Still the problem was the same.

Am using Intel DX58SO mobo for almost 4 years. It has two PCIE 2.0 16x slots and is working fine with my Sapphire HD 5770. So to further investigate i got my friends very old MSI p7n platinum and it worked !! The graphic card accepted the mobo or should i say the mobo accepted the graphic card ?? this board too has 2XPCIE2.0 16x slots which has a bios version dated in 2011.

I was breaking my head for the last 2 days and finally i got it through the bios !!!

1. I plugged my old hd 5770 in the primary pci adapter (with hdmi cable attached) and the hd 7950 on the secondary adapter (no video out ).

2. Powered up the 7950 with the 8 and 6 pin cables , the 5770 with molex to 6 pin adapter.

3. Switched on my pc. Both cards started running as expected.

4. Bios worked as it chose my 5770 as its primary display adapter. Bios also showed my 7950 in the second slot.

5. Went inside windows. My catalyst controller shows both graphic cards in the hardware information. (Primary adapter:5770, Disabled adapter:7950) So no problems with the cards.!!

6. To check if my 7950 works properly, i unplugged the hdmi cable from 5770 and plugged it in 7950 while still operating in windows, and it worked !! Display worked fine, videos, games worked.

But still my problem wasn't over, i cant keep swapping hdmi cable from 5770 to 7950 every time i switch on my system. so next,

7. I uninstalled all ATI drivers while still using 7950.

8. Restarted the system, with 5770 still attached. Now since the hdmi cable was plugged to 7950 and 5770 still on the board, bios somewhat accepted both the cards and let me through to windows !!! the problem here is that bios needs my 5770  :-[ and so it flew past bios and i landed directly onto the OS selection screen ( i use win 7,win 8 and Ubuntu ).

9. Went inside windows and installed the latest drivers.

10. Now my catalyst controller shows primary adapter as 7950 and disabled adapter as 5770.

To sum it up, I still need a latest bios update for my graphic card, till that time i can keep using this AWESOME card. The 5770 is eating up extra power, i have to find a low performance, low power consumption old gen card to replace this. And to go inside bios i have to remove the 7950. EVGA did a bios update for GTX 780 and it worked on DX58SO ! ( from another forum )