Official GIGABYTE Forum

16 gigs of ram installed. Windows 7 Professional 64 bit only reading 8 gigs

Hi guys :)

Bought two 8 gig Kingston Hyper Memory sticks for my PC from tigerdirect. Installed them but Windows 7 Professional is only reading 8 gigs. I've tested the memory slots and they both work. Both memory sticks work as well.

My motherboard is a Gigabyte GA78LMT-S2P
AMD Phenom II X6 1045T 2.6 GHz Processor
1 TB Hard Drive
ATI Radeon 3400 HD graphics card

Any help would be greatly appreciated :)

Vezina

  • 871
  • 10
  • If it s not broken, fix it until it is !
Maybe a BIOS limitation if you are sure you inserted them all properly in and that they work separately.
Depending on the sticks this can happen.
Over & Out !

AMD FX (APU-s included) users should install - KB2645594 & KB2646060 under Windows 7

1.ASUS Sabertooth 990FX 2.0 + FX 6300 + H60
2.MSI A88X-G41 PC Mate + A8 5600K + Hyper TX 2
3.Gigabyte F2A75-D3H + A4 5300
4.ASUS AM1M-A + Athlon 5150

AgentFXA

  • 372
  • 16
    • none
Some older boards have a limitation of 2 ram sticks if ram speed is set faster than 1333
X470 Aorus Gaming / Ryzen 2700x / GV-RX570AORUS-4GD / 16 GB HyperX Predator 3200  / SeaSonic 650W / Tt View 71 TG / Win10x64

Vezina

  • 871
  • 10
  • If it s not broken, fix it until it is !
Some older boards have a limitation of 2 ram sticks if ram speed is set faster than 1333

It s not related to the speed ,it s related to the stick configuration or the BIOS itself.

That X6 CPU has the best IMC in Phenom 2 series CPU-s ,it takes 1600Mhz RAM just fine and the IMC overclocks to 2,4-2,6 Ghz easily.
The board though is a cheap one and BIOS could be underdeveloped regarding RAM compatibility or amount.

I would test the CPU and RAM in a different motherboard.
That CPU is a nice one and with a better board you could get some "juice" out of it :)
Over & Out !

AMD FX (APU-s included) users should install - KB2645594 & KB2646060 under Windows 7

1.ASUS Sabertooth 990FX 2.0 + FX 6300 + H60
2.MSI A88X-G41 PC Mate + A8 5600K + Hyper TX 2
3.Gigabyte F2A75-D3H + A4 5300
4.ASUS AM1M-A + Athlon 5150

Did you check in Boot section in msconfig.exe, under Advanced Options, Maximum memory. It should be left unchecked or set to amount of memory you have installed. Try both settings.