Official GIGABYTE Forum

New Gigabyte Z77 Sniper M3 + 2700K - Overclocking woes and weird voltage behavio


  • 1
  • 0
Hi everyone,

This is my first post here but I'm hoping some of you can shed some light on the issues I'm facing. I recently purchased a Gigabyte Z77 Sniper M3 and a 2700K as Haswell did not impress with its performance and high levels of heat. I am not new to overclocking but this is my first Sandy/Ivy platform and my attempts at overclocking have left me extremely frustrated.

I have read and followed numerous guides and troubleshooting tips but nothing has helped so far.

Now I know what your thinking, "Your doing it wrong!" springs to mind. And I do hope that is the case as I am not looking forward to having to tear down my system again and RMA the board.

My first issue is that no matter what setting I use in regards to CPU voltage, it never gets applied even under load. I have tried:

Ratio: 45
Turbo: Disabled

Setting the vCore to a fixed voltage - VOLTAGE IGNORED

Setting vCore to Normal with an offset -or + - VOLTAGE IGNORED

What happens is that when i apply load to the cores, the vCore shoots up to 1.368, then 1.392 then finally settles on 1.440 which is way to high. This is regardless of any voltage setting I set in the bios.

The second issue is that when trying to trying to use Turbo mode to overclock, my turbo ratios is set are completely ignored and stay on the stock x35:

Base Ratio: x35

Turbo Ratio 1-core: x45
Turbo Ratio 2-core: x45
Turbo Ratio 3-core: x45
Turbo Ratio 4-core: x45

Turbo mode on Auto - CLOCK SPEED IGNORED

Turbo mode on Normal - CLOCK SPEED IGNORED

Setting base ratio to x45 to match Turbo ratio - CLOCK SPEED IGNORED

Using any of these settings only results in the CPU boosting to 3.5GHz under load.

I've now spent 2 solid days trying to figure out what is wrong but now I'm beginning to think that the motherboard is faulty and I am just wasting my time. Please help!



EDIT: I also forgot to mention that this is with multiple different BIOS versions. I have tried F9, F10c and F10f. All exhibit the same problems. I cannot try any earlier than this due to a compatibility issue with my HD7950.


3D Bios exhibits the same problem.

The problem is not the values applying in the bios, that is fine. Its just the voltages themselves are not being applied on CPU load. Its like its permanently stuck on Auto.

Ive also noticed that if i reset my BIOS, the M.I.T. screen works fine and is populated with value. As soon as I change anything in the bios (not just voltages/OC), save and reboot the M.I.T screen is blank again.

This only happens with F10c/F10f bioses. The M.I.T. screen for F9 is fine.

I was looking forward to this being my first gigabyte board, but at this rate I'll be returning this for the gene :-(