Official GIGABYTE Forum

Issues with Gigabyte Download Center

Issues with Gigabyte Download Center
« on: October 20, 2013, 06:46:53 pm »
Hi there,

I'm posting to find out whether anybody has and/or is having the same issues as me and whether anyone has found out any fixes to rectify the problems.

The issues I am currently experiencing with the Gigabyte Download Center are in IE10 but one issue has been reoccurring since we bought the PC (Zoostorm) at the end of last November or beginning of December and that is the Realtek HD Audio Driver not disappearing from the Downloads Page after downloading and installing the driver update and revisiting the Downloads Page. Below were supposed to be illustrations of the problems with descriptions but have been replaced with links instead, reason as to why I did this is in the paragraph at the end of the thread.  Reinstalled PC on 29/09/2013 due to component registry problems with Task Scheduler which were associated with the renaming of the main Admin account.

At first when clicking the “GO !!” button in the Gigabyte Download Center, the button isn’t responsive in IE9 and IE10 even with Compatibility View enabled and requires you to click the “If download center do not Function properly. Please Download Scanning element program Manually” to install InstallOBJ.exe component whereas in IE8 it prompted you to install the InstallOBJ.exe component with clicking the Information bar at the top of the window instead of at the bottom of the window, selecting Download, clicking Run > Yes to prompts and returns you back to the same page except when you clicked on the “GO !!” button immediately, it came up with a message saying “Please wait for DL program” in which you clicked OK and waited for component to register for a few minutes before clicking the “GO !!” button again.

However when revisiting the Gigabyte Download Center after downloading the InstallOBJ.exe component and initialising the Gigabyte Download Center in IE9 and IE10, the above message appears “This Driver can’t release to failure!!” after clicking “GO !!” Clicking OK produces the same message for another 3 times and produces the screenshot below.

Click “Close the program” and returns back to the same page saying that IE has recovered the page in the Information bar at the bottom of the screen in which you click Close.
 
Click “If download center do not Function properly. Please Download Scanning element program Manually” and you will be prompted by Information bar, click Run to install InstallOBJ.exe.
 
Click Yes to UAC prompt.
 
Click “GO !!” button to initiate wizard, produces “This Driver can’t release to failure!!” message in IE9 and IE10 whereas in IE8 it goes straight to scanning page, click OK.
 
On first use of the wizard, it comes up with the Download bar in IE8 to download the InstallOBJ.exe component in which you click the Information bar and then select Download in which the page refreshes and comes up with a UAC prompt, click Yes and wait for the page to load in which it’ll direct you to the downloads page whereas IE9 and IE10 go straight through to downloads page. However when returning to the wizard, IE8 prompts you to run the InstallOBJ.exe component in which you click Run and Yes to UAC prompt, IE9 and IE10 again go straight through to the downloads  page.

Downloads page comes up with all downloads related to the Motherboard components installed inside of the PC except it comes up with 2 of all, most of them exactly the same whereas some of them come up with different version numbers as illustrated in the screenshot above and below. Clicking “Click to Install All Drivers” and “Install” to each driver comes up with another loading page showing that the drivers are being downloaded and installed and return you back to the download page where the downloads are still present? Clicking “Save As…” followed by the Information bar prompting to Run or Save in IE9 and IE10 or to Download in IE8, if IE9 or IE10 click Run and then Yes to UAC prompt whereas in IE8 click Information bar, select Download, click Run and then Yes to UAC prompt and to follow instructions on screen to install each driver. Again when returning to downloads page it still says that I have got updates outstanding?  

Please could one of the moderators notify the developers to improve the validation messages so that they make sense in the program. Are there any ways in which these issues can be resolved? I.e. redesigning the program completely

Also I have tried using another web browser such as the latest version of Google Chrome and the program wouldn’t work due to it being ActiveX based instead of Java plug-in based for non-IE browsers, would this be possible to do? Also can anyone please let us know of any issues surrounding the Gigabyte Download Center with other non-IE web browsers.

Also throughout the process I have been using both 32-bit and 64-bit versions of IE8, 32-bit and 64-bit versions of IE9 and 32-bit and 64-bit versions of IE10 have been merged together.

Are some of these issues historical i.e. have they been present in other versions of Windows prior to Windows 7 and in other versions of IE prior to IE8? Also can anyone please let us know of this.

Many thanks,

RocknRollTim

Current Computer specs are:
OS: Windows 7 x64 Home Premium SP1
Motherboard: GA-H61-S2PV
CPU: Intel Pentium CPU G840 2.80GHz
HDD: 320GB (non-solid state)
RAM: 6GB
(This one has the issues described with IE10)

Previous Computer specs were:
OS: Windows XP SP3
Motherboard: GA-M68SM-S2L
CPU: AMD 64 Athlon 1.60GHz
HDD: 250GB (non-solid state)
RAM : 1GB
(This one had the issues described with IE8)

P.S. Screenshots of the processes are included in https://skydrive.live.com/redir?resid=1550B779A1E09442!2226 and are in order as the picture function doesn't allow to upload images with a certain number of pixels. Haven't tried Gigabyte Download Center with IE11 yet as it is only present with Windows 8.1, if anybody has tested this please could you notify users of any issues you encountered similar to mine.

Moderator Edit:
The image link shown above seems to be incorrect, so try this one instead: https://onedrive.live.com/?cid=1550b779a1e09442&id=1550B779A1E09442%212226
« Last Edit: June 14, 2014, 12:19:58 pm by absic »

Re: Issues with Gigabyte Download Center
« Reply #1 on: June 14, 2014, 12:12:21 pm »
I have also tested the Gigabyte Download Center in IE11 on Windows 7 and the same issues happen again, I even followed the instructions to the tee on the website in IE and the same number of downloads appear in the list even though they aren't needed.

RocknRollTim

AndyW

  • 1
  • 0
Re: Issues with Gigabyte Download Center
« Reply #2 on: October 11, 2014, 10:10:45 pm »
Well said, Tim. I have just been through the same rigmarole: tried using the Download Center on much the same kit - IE11 under 64-bit Win 7 SP1, and got the message Please wait for DL-Program. So manually downloaded and ran Installobj.exe, which appears to call Dllhost.exe for a few seconds. With no discernible result. Return to Go!! at the Download Center and that completes the loop.

Any chance of some help at Gigabyte?

AndyW

Re: Issues with Gigabyte Download Center
« Reply #3 on: October 12, 2014, 12:18:20 am »
Hi Andy W,

Glad to hear that someone has come forward with the same issue as me, I thought I was going to be alone with this issue and thanks for supporting me. I have submitted a ticket to Gigabyte email support containing the URL of this forum thread so hopefully we might have some answers as to why the Download Center isn't working as expected. I'll keep you posted on this when I get some answers.

Kind regards,

RocknRollTim

Re: Issues with Gigabyte Download Center
« Reply #4 on: October 12, 2014, 02:46:22 pm »
By the way Andy W, welcome to the forum.

Regards,

RocknRollTim

Re: Issues with Gigabyte Download Center
« Reply #5 on: October 18, 2014, 08:58:06 am »
Hi Andy W,

I just got a response from the email support team last night and they said they have escaluated the issue onto the software team to deal with, hopefully we'll have some more answers soon in which I'll continue to keep you posted.

Kind regards,

RocknRollTim

Lajon

  • 2
  • 0
Re: Issues with Gigabyte Download Center
« Reply #6 on: October 23, 2014, 06:22:55 pm »
I just wanted to update everything before I get Beyond Earth as it supports AMD Mantle and  I have to say this is all rubbish. I get different version from DC and different from Gigabyte website. This is my first MoB made by the Gigas and I am really put of  by all of this.
Not to mention that I is not that easy to install it DC  :)

Re: Issues with Gigabyte Download Center
« Reply #7 on: October 23, 2014, 06:40:11 pm »
Hi Lajon,

Thank you for also responding to my forum thread and for expressing your opinion but regardless of what I have said in this thread I have asked Gigabyte email support to look into the issue and to keep you all posted. By the way welcome to the forum Lajon. :)

Kind regards,

RocknRollTim

Lajon

  • 2
  • 0
Re: Issues with Gigabyte Download Center
« Reply #8 on: October 23, 2014, 07:05:13 pm »
Hallo.
Thank you.
I just wanted to add that the versions are also different sometimes as it is a bit confusing.
All the best

Re: Issues with Gigabyte Download Center
« Reply #9 on: October 23, 2014, 07:08:20 pm »
That's fine Lajon, thanks for adding the info to my thread and for Gigabyte to become more involved in solving this issue.

Regards,

RocknRollTim

Re: Issues with Gigabyte Download Center
« Reply #10 on: October 29, 2014, 10:41:43 pm »
Hi guys,

I keep getting a response every Sunday from the Gigabyte email support to say that their developers are on the case, could be a long wait until I get a solution, however I'll still keep you posted of where they are up to with this case.

Kind regards,

RocknRollTim

Re: Issues with Gigabyte Download Center
« Reply #11 on: November 17, 2014, 08:18:37 am »
Actually so I've had responses from email support on 24/10/2014, 30/10/2014, 06/11/2014 and 13/11/2014 and they all say they are still working on my inquiry, sorry for the delay and we will keep you update asap. My post saying that they have been keeping me posted every Sunday isn't true.

dmdilks

  • 2899
  • 34
  • "If it isn't broke don't fix it"
    • http://dmdcomputerservice.webs.com/
Re: Issues with Gigabyte Download Center
« Reply #12 on: November 17, 2014, 02:04:45 pm »
I got it to work in IE 9. But I had to manually download the driver. Then I can click on the go. Will not work in Google Chrome.

But it will come up and say This Driver can’t release to failure and than it runs and tells me I don't need any drivers.

Yes they are having problems, but I don't put things on my computer that will do stuff like this. That is just me.

I have learn years ago that all those nice little programs that are out there are really a waste of time.  ;)

Yes it is nice that you can click on that and it will tell you if your drivers are up too date.  :)

I have been with Gigabyte ever since Abit closed. That is the first time I used the download center.

Plus the other thing is it is telling you this too, before you do anything. I check and I couldn't find it.

Microsoft update 912945 will cause conflict with GIGABYTE Download Center. Please remove Microsoft update 912945 first before using GIGABYTE Download Center.
GIGABYTE-GA-GA-X99-UD4 i7-5820K 3.30GHz, ADATA XPG Z1 32GB DDR4 2400 Quad, HIS R9 290X IceQ X2 4GB, In Win Glacier 900W, Cooler Master HAF 932, 2-240GB SSD sata-3, Win7 Ult-64bit 39" LED TV

Re: Issues with Gigabyte Download Center
« Reply #13 on: November 17, 2014, 05:37:46 pm »
Same here dmdilks I can't find the update to remove before using the Gigabyte Download Center either but I understand what you are saying about the Gigabyte Download Center though, it is a bit of an effort to use on modern Operating Systems especially how it is at the moment.  :)
« Last Edit: November 17, 2014, 05:46:50 pm by RocknRollTim »

dmdilks

  • 2899
  • 34
  • "If it isn't broke don't fix it"
    • http://dmdcomputerservice.webs.com/
Re: Issues with Gigabyte Download Center
« Reply #14 on: November 18, 2014, 03:34:24 pm »
Like I said before I don't tell people how to run they computers. I was the same way years ago. Ran all those nice programs that did all of that nice stuff. Today I only run one program.

That is one antivirus program Malwarebytes that is it. Now with updates I don't do them. I feel bios & driver updates are for people that are having problems. I have a saying "Don't Fix What Isn't broke".

I have a small problem with my computer no big deal. But it will BSOD here and there. I know what it is too. It is the driver for the video card. But I can't do a update because the newest driver will make my 39" LED TV look like crap.

The thing I don't understand is that Gigabyte has this Download Center and they didn't know they were having problems with it. Plus the people that do like using the Download shouldn't have to jump through hoops to get it to run.
GIGABYTE-GA-GA-X99-UD4 i7-5820K 3.30GHz, ADATA XPG Z1 32GB DDR4 2400 Quad, HIS R9 290X IceQ X2 4GB, In Win Glacier 900W, Cooler Master HAF 932, 2-240GB SSD sata-3, Win7 Ult-64bit 39" LED TV