Official GIGABYTE Forum

GA-X58-USB3 MBo won't boot/post

GA-X58-USB3 MBo won't boot/post
« on: October 24, 2013, 09:45:03 pm »
I recently bought supposably new GA-X58-USB3 and some other parts to renew my PC. It came sealed in a anti-static bag and looked new.
When I turn my PC on, all 6 leds on MBO light up, all the fans work but MBO doesn't post beep and monitor remains blank. Just random silent crackling sounds are heard from PC speaker.
After that, I tried removing all 3 RAM memory sticks but left everything else in PC, and when I turn it on, still no beep or screen.
I took Mbo out off PC case and left it with only CPU and its fan connected to PSU, and got no beep.
Then I tried sticking only one RAM stick in Mbo, still no beep upon powering up.
Then I put all 3 RAM sticks back in and turned it on, without VGA connected. I got a long melodic beep.
Does this mean that MBO is functioning? I am woried that I get no post whatsoever with no or only one RAM sticks pluged in.
Could some other part of PC beside MBO cause the malfunction here? What should I do?


  • 2923
  • 34
  • "If it isn't broke don't fix it"
Re: GA-X58-USB3 MBo won't boot/post
« Reply #1 on: October 25, 2013, 01:33:19 am »
The memory should be in the white slots. On the Video card does it need power. Make sure you don't have any bent pin in the CPU socket.

Plus you have a double thread here and you should delete the other one if you can.
« Last Edit: October 25, 2013, 01:34:28 am by dmdilks »
GIGABYTE-GA-X299-UD4, i7-7820X 3.60GHz, ADATA XPG Z1 32GB DDR4 2400 Quad, RX-580-8GB, In Win Glacier 900W, Cooler Master HAF 932, 1-240GB SSD sata-3, Win7 Ult-64bit, 1-M2-SSD-128gb Win 10 pro 64bit, 39" LED TV

Re: GA-X58-USB3 MBo won't boot/post
« Reply #2 on: October 25, 2013, 10:43:50 am »
Checked the pins - they are good as new.
I checked all the connections multiple times, and RAM is in the right slots. PleaSE gimme some suggestion not ment for newbies, cause I am building my rigs for 15 years now, and mostly know what I am doing.


  • *
  • 5766
  • 520
  • Never give up; Never surrender!
    • Bandcamp
Re: GA-X58-USB3 MBo won't boot/post
« Reply #3 on: October 25, 2013, 12:53:32 pm »

what parts are you using; CPU, PSU, RAM Modules, VGA, etc as this will help with troubleshooting.
Remember, when all else fails a cup of tea and a good swear will often help! It won't solve the problem but it will make you feel better.

Re: GA-X58-USB3 MBo won't boot/post
« Reply #4 on: October 26, 2013, 01:26:09 am »
Hi, I determened what caused the problems. Here is the story.

 I bought this new Gigabyte MBo and i7 CPU cause my old MBo (ASRock X58 Extreme) burned out in smoke literaly, what happened near the CPU (chip with 1R1 label). I knew that CPU (i7 920) was also destroyed cause the meltdown on MBo was so severe that it started to burn trough the back side of PC case. So I bought new MBo (GA-X58-USB3) and CPU (i7 950) cause I found them at bargain price of 350$ for both. I put the old and new components together and PC failed to post any beeps and screen was blank. Then I posted the initial question.
Today I went to my friends home and tested out my components separatly (new MBO and CPU, old  GPU and RAM) on his comp.
I did not suspect further results.
 It turned out that my old GPU (XFX Radeon HD5830) was also destroyed in the ASRock X58 Extreme meltdown, along side 1 of 3 sticks of my Corsair Dominator 1600 DDR3.
2 sticks (4GB) of DDR3 survived the meltdown, and probably work (only the 3rd stick reported error on boot when i tested them 1 by 1).
After finding all this, my conclusion is that a bad quality MBo is worst thing your PC build.
Although my ASRock X58 Extreme lasted 4 years without any problems, in one moment it wiped out itself, CPU, GPU and 1/3 RAM. Or maybe my PSU (OCZ Silent XStream 2)caused the meltdown?
Can somebody advise me is it safe to try to use my old PSU that was present during the meltdown, or is it probably faulty as well?