Official GIGABYTE Forum

BRIX i7 4770R does not boot after BIOS change

BRIX i7 4770R does not boot after BIOS change
« on: May 26, 2014, 03:14:41 pm »
Purchased this little monster 2 weeks ago. Everything OK until I checked the drivers page and noticed that there is a BIOS update.

F4   5.28 MB   2014/03/10
1.Add "Operation mode" feature fan curve.
2.Modify vBIOS. Set display priority to single display output(HDMI > mDP).
3.BIOS Setup support mouse function.

After applying this update (windows flashing tool reported success after verifying the update process) and reboot the power light goes blue but nothing comes up on the screen.
What I did up to now:
1. Hit Del or F2 immediately after power on waiting for BIOS screen - nothing
2. removed all the attached devices and rebooted manually - nothing
Connection to monitor - HDMI.

I opened a ticked with gigabyte support but so far no answer.
Any advice on this?
Thank you.

Re: BRIX i7 4770R does not boot after BIOS change
« Reply #1 on: May 27, 2014, 09:51:13 pm »
After messing with the BIOS and changing my video card to EFI mode, I also got it where it wouldn't show anything on the screen.

I had to disassemble it, unplug the CMOS battery. Wait 15 minutes. Plug it back in and it will put BIOS settings to default.

Might get yours to start working again.

Re: BRIX i7 4770R does not boot after BIOS change
« Reply #2 on: May 28, 2014, 04:25:27 pm »
Thank you. I've returned it and the vendor will replace it with another one. I'm not sure that I'm qualified nor do I have the tools to disassemble this little thing. I had 30 days coverage from the store for returning and I took advantage of it but after that I might probably try to do that.Thanks again.

Re: BRIX i7 4770R does not boot after BIOS change
« Reply #3 on: December 21, 2014, 07:25:43 pm »
Same problem here with my brix pro: Must remove all, tiny UFL connectors and CMOS battery. BIOS is unstable I don't like this I return it to Amazon for a REFUND...

 

anything