Official GIGABYTE Forum

GeForce GTX 750 Ti drivers mess with my Wi-Fi card

acerne

  • 1
  • 0
GeForce GTX 750 Ti drivers mess with my Wi-Fi card
« on: October 26, 2014, 04:14:20 pm »
Hi,

I built a new computer with the following specifications:

Motherboard: Gigabyte Z97X Gaming 5
Processor: Intel i7-4790K
Graphics card: Gigabyte GTX 750 Ti
Wi-fi card: Digitus Wireless 300N PCI adapter
Main display: LG ultra-widescreen (21x9) (first HDMI input)
Secondary display: some older LG LCD display (second HDMI input)
and the rest of the components are probably not important.
I am running  64-bit version of Windows 7.

I am having problems with my Wi-Fi and I suspect it has something to do with the graphics card. The problem is that the Wi-Fi is unable to connect to the network in some cases. I tried a different PCI Wi-Fi card and it's the same problem. This happens when:
  • I install all of the drivers on the graphic card's CD.
  • wifi works with only the basic driver installed, untill I plug in the secondary display. The same second the monitor is plugged in, the Wi-Fi signal is lost.

But even in that case when Wi-Fi works, I am having only 10-20% of my network speed. In addition, at some times the mouse is hard to control (jumps over the screen instead of moving smooth) and the sound is pretty badly distorted at the same time.

Can you help me with this problem? I'm pretty sure it's something related with graphic's card. If you need anything more detailed, I'll be happy to elaborate.

I was really looking forward to build a decend PC, but now I spent 4 days only messing around with this... Hopefully you are able to help me.

Best regards,
Aleš

 

anything