Official GIGABYTE Forum

Gigabyte 970A-DS3P New build...Windows can't find the hardrive

Gigabyte 970A-DS3P New build...Windows can't find the hardrive
« on: February 03, 2015, 03:29:56 am »
Hi:

New computer build:

Gigabyte 970A-DS3P AM3+ DDR3
WD 1TB SATA lll Desktop Hardrive
Seagate Barracuda 250GB SATA ll Desktop Hardrive
AMD FX 4300 PILEDRIVER 3.8GHZ QUAD CORE SOCKET AM3+ CPU
Gigabyte GV-N210SL-1GB GeForce 210 Graphics Card
Crucial CT51264BA160BJ 4GB DDR3 SDRAM 1600MHz x2
Alpine Blue 700W 38 AMP Single Rail PSU

Turned it on for the first time this evening, lovely... Spent the last 6 hours trying to get Windows 7 to find any hard drive...

If I dumb the BIOS down to IDE and Legacy boot mode I can manage to get the Install Windows GUI to appear but it won't see any hard drive... It will recognise a USB stick with the SATA AHCI unzipped drivers on but only if I untick "Hide drivers that are not compatible with hardware on this computer". Anyway, I select one of the four 'AMD SATA Controller(C;\SATA_AHCI Driver\AHCI_w7\W764A\amd_sata.inf)' and click Next and all I get is "No drives were found. Click Load Driver to provide a mass storage driver for installation."

It's a new Western Digital hardrive... I had it in my regular computer and fully partitioned it with NTFS default settings and left a completely empty 70GB C:\ drive all ready for a fresh Windows installation...in theory.  There is also a 250GB SATA ll hardrive in there just for data... It doesn't see that one either.

If I leave the BIOS at AHCI it doesn't get past the Starting Windows screen...

Any ideas?   Thanks in advance?
« Last Edit: February 03, 2015, 04:06:22 am by fonebone »

Re: Gigabyte 970A-DS3P New build...Windows can't find the hardrive
« Reply #1 on: February 03, 2015, 02:52:06 pm »
Mystery solved.  After 6 hours tooling around with the manual and the BIOS a bright spark suggested setting the BIOS back to the default and Bingo !!  I had to delete the MBR partitions that I previously created, it didn't like them ("On EFI systems windows can only be installed to GPT disks" ) but I now have W7 installed on a GPT setup.

Many thanks for any interested readers.

 

anything