Official GIGABYTE Forum

GA- Z97-HD3 problem POSTing SOLVED


  • 2
  • 0
GA- Z97-HD3 problem POSTing SOLVED
« on: September 21, 2015, 12:55:15 am »
My 3 month old GA- Z97-HD3 suddenly started having a problem not POSTing.
As I said it happened suddenly after running flawlessly for 3 months (literally nothing had changed on the computer), I just restarted it after installing some Windows updates and the machine started beeping and not POSTing. I thought I was in real trouble because this is my work machine and I figured I was in for a long RMA process. I removed the board and all accessory cards from the case and put it in a breadboard set up. I had a known good PSU which I used just to eliminate that as the problem - no change - no POST. I re-installed the CPU - no joy. I was about to give up and RMA it when out of desperation I tried moving the RAM sticks around and voila it POSTed. I was back in the BIOS, but when I restarted, it again wouldn't POST. The only way I could get it to POST was by again moving the RAM sticks to different slots (kind of like musical chairs with RAM). I decided that I should check and see if there were any BIOS updates for this model and there were. I was on F7 and the latest BIOS was F9 which I downloaded. Now if I could only get it to POST one more time so I could run the BIOS update, then I might get up and running again. Of course there was no guarantee the new BIOS would fix my particular problem, but at that point I has nothing to loose. After moving the RAM sticks once again, it POSTed and I got into the BIOS so I could update it. I ran the update and so far, everything is working fine again. I've restarted, shut down, restarted dozens of times to test it and so far so good. As long as it keeps working, I'll be happy, despite the huge scare. Obviously, the newer BIOS fixed some issues with RAM timings and the CPU RAM controller (and maybe some RAM voltage tweaks as well).


Intel i7 4970k
Corsair RAM
Crucial SSD
Corsair AXi PSU
Thermal-Take case