Official GIGABYTE Forum

Gigabyte site - support

Margie

  • 1
  • 0
Gigabyte site - support
« on: March 06, 2016, 02:34:44 am »
Hi all.  I have found it impossible to register with the Gigabyte site.  I tried to register both with my own details, then with Facebook, neither works.  I really need to get in so how do I do it?
« Last Edit: March 10, 2016, 01:47:47 pm by runn3R »

Re: Gigabyte site - support
« Reply #1 on: March 09, 2016, 08:20:33 am »
Hi all.  I have found it impossible to register with the Gigabyte site.  I tried to register both with my own details, then with Facebook, neither works.  I really need to get in so how do I do it?
I've also had this problem.
I tried to open a support question, it took me (eventually) to the page at https://passport.gigabyte.com/Apply.aspx. When I filled it in and clicked submit it did the postback but the result was an ASP.NET error (in Chinese) telling me that an error occurred but custom errors is enabled.

Please, Please can someone at Gigabyte fix this issue. I've got an almost brand new graphics card that doesn't appear to be working correctly that I want help with and cant get it. This is made even more frustrating by the lack of any other way to contact them. Not even a phone number.
If there isn't a fix in the next few days then I'll have to return the graphics card under DSR and just never risk buying Gigabyte again. :(
« Last Edit: March 10, 2016, 01:48:04 pm by runn3R »

runn3R

  • *
  • 1328
  • 57
  • Admin
    • GIGABYTE UK
Re: Gigabyte site - support
« Reply #2 on: March 10, 2016, 01:57:26 pm »
Hi Both

I have checked this today at: http://www.gigabyte.com/support-downloads/technical-support.aspx.
Tried 2 ways: Facebook account and GIGABYTE Passport (I also created Passport account from scratch). No problems found - I successfully submitted 2 support tickets.
Please try using different browser of if you still have problems then let me know via PM. Thanks
ZX-S & C64 are still my favourites ;-)

 

anything