Official GIGABYTE Forum

GA-X99P-SLI - Thunderbolt error message


  • 5
  • 0
GA-X99P-SLI - Thunderbolt error message
« on: August 16, 2016, 06:12:42 pm »
I haven't been able to install the Thunderbolt software correctly so far. The Windows Device Manager doesn't show any errors, the software was installed successfully but each time I boot I get this message "Your PC may need updates for the Thunderbolt 3 port to function properly. For more information go to: https://thunderbolttechnology/net/updates"

I tried the Thunderbolt drivers from the  GA-X99-SLIP support page and the newer ones from Intel (

The software seems to work but I can't test this tech since I don't have any Thunderbolt devices yet, I just want the error message to go away.

I am running Windows 10 x64 (v1607). Thunderbolt is enabled in the BIOS.
« Last Edit: August 16, 2016, 06:13:56 pm by ymmv »

Re: GA-X99P-SLI - Thunderbolt error message
« Reply #1 on: November 21, 2016, 08:40:46 pm »
Any progress with this error? I just ran into it last night. I have a USB-C to USB 3.0 Adapter that plugs into the USB-C port and it works. It even worked before I applied the Thunderbolt update. I even tried uninstalling the "Thunderbolt(TM) Software" but it doesn't respond.


  • 2
  • 0
Re: GA-X99P-SLI - Thunderbolt error message
« Reply #2 on: November 22, 2016, 05:36:00 pm »
Same problem here.... Hey Gigabyte take our ticket here!  >:(
Win 10 and thunderbolt annoying alert every boot! I've tried, installed any suggested driver from Gigabyte official page, and followed the instruction placed at this link
I'm very disappointed now, fix this please!

Re: GA-X99P-SLI - Thunderbolt error message
« Reply #3 on: November 24, 2016, 05:41:36 pm »
Same here with the X99P-SLI with F23 Bios and running the latest ( from Intel too. I even upgraded the Firmware using the Gigabyte app. This is likely an Intel software bug and not Gigabyte but anyone successful got ride of this message on startup?

Re: GA-X99P-SLI - Thunderbolt error message
« Reply #4 on: November 25, 2016, 01:59:23 am »
Think I solved it but not sure what exactly fixed it. I uninstalled the software, and then re-installed. Then rebooted and went into the BIOS to disable Thunderbolt in the BIOS, booted up into Windows. Then rebooted and enabled Thunderbolt in the BIOS. Updated Firmware again (apparently it doesn't know that I already did this). Anyway, I don't see the message any longer now.

Re: GA-X99P-SLI - Thunderbolt error message
« Reply #5 on: March 11, 2017, 08:24:04 pm »
Same problem here in Windows 10... hmmm what to do?


  • 1
  • 0
Re: GA-X99P-SLI - Thunderbolt error message
« Reply #6 on: May 02, 2017, 08:34:31 pm »
The issue is the poorly worded instructions - after you have unzipped the firmware update utility - when you run the setup exe it doesn't actually do the firmware update. It just installs the firmware update tool.

1. Unzip the download e.g.
2. Install the firmware updater from the unzipped folder
3. Run the firmware update tool from e.g. C:\Program Files (x86)\GIGABYTE\FlashTBT