Official GIGABYTE Forum

Gigabyte RX 480 G1 Gaming 8gb bios flash problem

Gigabyte RX 480 G1 Gaming 8gb bios flash problem
« on: February 19, 2017, 02:27:17 pm »
Hello all,
I bought this graphic card in December and it had F7 bios on board.
I downloaded the new bios from Gigabyte and used the tool that came with the download.
I had started the tool as admin on a windows 10 pc, after the flash, blank screen and no  matter what i tried, no more display. Bought another one, send the broken one back to Gigabyte and luckily Gigabyte managed to bring live back to the card. But it still had F7 version bios. So with to cards i tried to flash again, this time using vga@bios tool and again...... blank screen.
Again, great support from Gigabyte, but this time they flashed F8 to the card.
The questions:
Can someone explain to me why my flashes didn't work (I flashed many bios files in the last 20 years)
I am planning to go for a crossfire setup, will the difference in bios files affects operations?
Are the benefits of the F8 bios version, worth to try again?
« Last Edit: February 19, 2017, 03:43:09 pm by »

Re: Gigabyte RX 480 G1 Gaming 8gb bios flash problem
« Reply #1 on: March 12, 2017, 08:53:29 pm »
I too have flashed many a BIOS with no problems. However, I have noticed that very occasionally a flashed device will be treated as a new device and require driver reinstallation. This should happen automatically, though, so after five minutes post power cycle it should still work. One thing I have noticed is that AMD cards often don't like being installed with more than one monitor attached, and will give a black screen on both monitor until a hard reboot with a single monitor attached. Could this be what's happened to you?

Re: Gigabyte RX 480 G1 Gaming 8gb bios flash problem
« Reply #2 on: March 14, 2017, 01:23:46 am »
Nop, i have only one monitor attached.
And this was no driver issues.
I even tried it in a second pc, i am convinced i soft bricked it somehow.
Thinking some background software was interfering, but with the second bad flash, i made sure i had admin right, closed avp and other unnecessary software.
No i am thinking that it maybe was windows 10 it self?