Official GIGABYTE Forum

GA-Z270X-Gaming 9 BIOS Update - Lost Raid

GA-Z270X-Gaming 9 BIOS Update - Lost Raid
« on: April 20, 2017, 01:15:28 am »
I'm hoping someone can help. I just installed this new board in a RAID 1 configuration with 2 M2.2280 SSD drives. This was set up using the Intel RST - UEFI RAID. Everything worked perfect until i decided to upgrade the firmware. I was on F2 and upgraded to F3 using @BIOS. The BIOS update succeeded, but when it restarted it restarted in BIOS with the following errors:
-ROM Image not loaded
-ROM Image Update Denied
It appears the BIOS update reset everything back to default, and thus the RAID was not set up.
I changed the Windows 8/10 feature back to Windows 8/10 and CSM to disabled. Then I recreated the array and tried to reboot. Then it came up with "Inaccessible Boot Drive"
It seemed my only option at this point was to start over, which i did and everything is now normal.
Does anyone know why this happened and how to prevent this from happening again? This is a relatively new board and I'm sure future BIOS updates will come out that would be nice to take advantage of, but the data loss portion is as most of you know not fun. Obviously i will create a system image and back-up prior doing anything like this again.

Thanks for any suggestions -


  • 1403
  • 39
  • Xbox One, Drives STI, Use QVL RAM For Best Results
    • Gigabyte US
Re: GA-Z270X-Gaming 9 BIOS Update - Lost Raid
« Reply #1 on: April 20, 2017, 03:09:02 am »
This seems to be the end result after BIOS upgrade now that UEFI RAID is incorporated into the BIOS and not in a Legacy Option ROM.  You are the second person I've talked with, and it is certainly concerning for those of us who use RAID.  I'm on SSD's with an option ROM.  Its the m.2's that appear to be susceptible to this hazard. 

Since you are past troubleshooting, we can only speculate on what you might have been able to try.  Did you try removing one drive, and setting the existing RAID values in BIOS without creating a new array and writing metadata to the remaining disk member?  If so and that failed, the only remaining option is to re-create the array and restore an image from back up.  (or re-install)

Of course nothing replaces a system image.  Hardware breaks, Arrays fail and the harder lessons are the self inflicted ones.  Painful for sure and new build or old, I feel for you man.  :(

In these cases, a back up should always be your first step.  I always disconnect my drives when performing a BIOS upgrade.  But I have not yet performed a BIOS update on a UEFI RAID z170/z270 BIOS with m.2's.   

SOP is that you upgrade and restore from back up.  Its just common practice, but its easy to get caught off guard as the whole implementation of M.2 support in the main BIOS has been evolving rapidly the last few years.  Hopefully you are stable now and won't need to upgrade again.  If you do , the back up you mentioned will ease the pain.
« Last Edit: April 20, 2017, 03:12:04 am by shadowsports »
Z97X-UD5H (F8) \Corsair RM850w, 4790K, 16GB Vengeance, GTX970 FTW SC 4GB ACX 2.0, 850 Pro's RAID0, W10 1709
Z370-HD3P (F5) \750w, 8350K, 8GB LPX 3200 - 16-18-18-36, GTX 660 FTW, Intel SSD, W10 1709
Coming soon: Z370-Gaming7 \850w, 8700K, 32GB LPX 3200, GTX 1080, 960 Pro m.2, W10