Official GIGABYTE Forum

BIOS doesn't detect new SSD, but Windows installation does.

Bought a Gigabyte barebones system and started setting it up yesterday. Put windows 10 onto a USB and installed it onto the SSD (I had to convert the SSD into GPT format otherwise windows refused to install)

The bios 99% of the time will show the serial ata port 0 as empty. if I set the sata mode selection to AHCI, it can't detect the SSD at all (it won't even see it when trying to prioritise where to boot from). I can only set the boot priority using Intel RST, but the serial ata port 0 is still empty.
I then set the bios to boot first to the SSD (windows boot manager) but it will not boot up at all. It goes straight into UEFI and one other time gave me the error ("The operating system couldn't be loaded because the kernel is missing or contains errors. File: \Windows\system32\ntoskrnl.exe").

I connected an old hdd in AHCI mode and the bios detected immediately but I have connected my ssd to my laptop using a sata cable via usb and it appears to work fine. I've tried updating the bios using Rufus and making a bootable USB but it even refuses to load that.

I've setup many PC's before but I'm pulling my hair out over this. How does the windows installation detect the SSD, install windows but then the BIOS doesn't even detect it? Any help would be greatly appreciated.

Spec:
PC: Gigabyte Kaby Lake i3 BRIX S Barebone Mini PC Kit with 2.5" SATA Bay GB-BKI3HA-7100
RAM:Corsair Memory 8GB (1x8GB) DDR4 SODIMM 2133MHz
SSD: Samsung 750 EVO 120 GB 2.5 inch Solid State Drive

Re: BIOS doesn't detect new SSD, but Windows installation does.
« Reply #1 on: July 03, 2017, 09:54:11 pm »
Solved it. I had update the BIOS with the latest version and it worked instantly.

When UEFI comes up, find the USB directory with the flash files on there, mine was fs0. (You can use rufus to make a bootable disk with the new files)

Type fs0:
and then flash.

 

anything