Official GIGABYTE Forum

Aorus Gaming K5 PCIe SATA cards not working

Aorus Gaming K5 PCIe SATA cards not working
« on: July 31, 2017, 06:47:26 pm »
Since I do not have enough SATA ports (specs for this board are misleading: 8 SATA ports + 2 SATA Express ports does not mean 10 ports in total), I have installed a couple of PCIe SATA cards to expand my SATA ports. The SATA expansion cards I am using are IOCREST SY-PEX40039 based on the Asmedia 1061 SATA Host Controller. These cards worked fine on an old Gigabyte Intel M/B.

They are detected in the AMD M/B, but:

1) If drives are plugged into them at startup, my Windows Server 2016 Essentials system hangs at startup.

2) If I plug drives into them while the system is running, the system immediately crashes.

I've tried it with the standard MS AHCI drivers and the ASM 1061 drivers and the result is the same.

I've ordered a SUPERMICRO AOC-SAS2LP-MV8 PCI-Express 2.0 x8 SATA / SAS 8-Port Controller Card so I can run my drives at full speed, but I'd like to get them working before it arrives.  And I have no idea if the SAS controller card is going to give me the same problems as the ASM 1061 cards.

Re: Aorus Gaming K5 PCIe SATA cards not working
« Reply #1 on: August 01, 2017, 12:19:52 am »
Finally have all my extra driver working.  I used a set of old Silicon Image 3132 Raid controller cards, even though I'm not using the RAID part. They were finicky to get working.  Didn't work in some PCIe slots, sometimes only saw 1 out of 2 drives in others.  The card's RAID BIOS hangs for a few minutes when booting, but the drives are visible in Windows.  Only working at 3GB/s speeds, but it will hold me over till my SAS 8x HBA arrives.