Official GIGABYTE Forum

GA-Z170X-Gaming 7 (rev. 1.0) BIOS

GA-Z170X-Gaming 7 (rev. 1.0) BIOS
« on: August 23, 2017, 07:26:47 pm »

I've been bumping into a few issue's with this motherboard "GA-Z170X-Gaming 7 (rev. 1.0)" I have the F20 BIOS installed, which I manually updated when I first received this board, but I'm unable to upgrade to the F21,...

I was going to reply to this post here, https://forum.giga-byte.co.uk/index.php?topic=18248.0 ,however, jumping another's thread isn't a nice thing to do, so I'll just link it, as it's virtually the same problem.

The very latest BIOS release is now the F22f which for some reason does not show up in the @BIOS app within the app center and only the F21 is showing up, is there any reason why the very latest BIOS is not being shown as a viable upgrade within the BIOS update program?... yet it's clearly visible and available via the webpage for this very motherboard here https://www.gigabyte.com/Motherboard/GA-Z170X-Gaming-7-rev-10#support-dl


I also noticed that the F20 BIOS came with a warning that you'll be prohibited in downgrading to any earlier versions of BIOS, maybe there's been some sort of an oversight and it's also prohibiting people from upgrading also,... I say this jokingly of course.

Moving on, I've also noticed that a high percentage of people who have been having these upgrading issue's have had NVMe installed via the 2 x M.2 slots,... such as I have samsungs 2 X M.2 NvMe 250GB,.. Could this be one of the factors disallowing the upgrades? (although, I admit, I very much doubt it), but still worth asking anyway?


I'm still trying to upgrade, though I've not attempted @Caerus solution yet and I'm somewhat put off trying it just in case it'll break my
RAID-0 with the 2 x M.2 slots as this is my main "C drive for booting",...giving I'm not all that familiar with dealing with RAID arrays I'm unsure how to save the array, I know I could disconnect them, but would I still be able to upgrade the BIOS without them connected?


If so, I suppose I could disconnect,...upgrade the BIOS (somehow, hoping the long solution above will work)  turn off the machine, reconnect the two M.2's and boot into the BIOS and just try reconnect the RAID-0... do I have that correct,.. Please?




If anyone could please explain a few of the above concerns I have, I'd be grateful for the support,... I Thank anyone for any support on this matter

Regards
« Last Edit: August 23, 2017, 07:28:45 pm by Alienmoon »
Intel - i7-6700K
Mobo - GA-Z170X-Gaming-7
GPU - Gigabyte Aorus 1080TI
Samsung - 2 X M.2 NvMe 250GB.
CASE - NZXT NOCTIS-450 Black.
COOLING - NZXT Kraken X62 AIO.
NZXT - Hue+
NZXT - Enclosed USB Hub
PSU - Leadex Gold 1000W PSU.
Corsair - 32GB Dominator.
Corsair - M65 Pro Mouse
Corsair - K70 Keyboard

Re: GA-Z170X-Gaming 7 (rev. 1.0) BIOS
« Reply #1 on: August 23, 2017, 09:31:34 pm »
Hello,

Not sure why the BIOS doesn't update using Qflash but it could be related to the type of BIOS. Full numbers are considered final releases, usually anything with a letter after, like 22f, is a beta.

The RAID controller stores part of the RAID setup along with the drives.
If the RAID controller's firmware is reset you may lose the array. <A BIOS update can do this

Suppose you did update the BIOS and the RAID0 array is not detected.
Trying to create a new array with 2 drives that where already part of an array is risky. Provided you match the options there is a chance it will work (and you dont erase the drives during creation of the array).

Usually the BIOS updates try to retain the previous settings and pass them over to the new BIOS but again it depends on the BIOS and what Gigabyte have set, some BIOS updates require all the settings to be set to defaults once completed.

50:50, change it might work.
If the data is important I suggest you backup first, create an image?

« Last Edit: August 23, 2017, 09:33:26 pm by ElectroStingz »
My PC is evolving

shadowsports

  • 2200
  • 66
  • Xbox One, Drives STI, Use QVL RAM For Best Results
    • Gigabyte US
Re: GA-Z170X-Gaming 7 (rev. 1.0) BIOS
« Reply #2 on: August 23, 2017, 11:54:14 pm »
Alienmoon,
You will loose the array if you flash.  Based on feedback from others, all have lost their m.2 arrays after a flash.  As ElectroStingz pointed out, the ability to recover varies and is based on several factors.  I myself have recovered using Legacy option ROM and SSDs and/or spinners, but NVMe's has thus far proven difficult since the RAID Option ROM has not been included in the UEFI portion of BIOS.

About BIOS revisions and betas.  Ones ending with a letter.  IIRC @BIOS only displays "final releases" not betas, but the option to display betas might exist (checkbox) depending on the version. 

Follow ElectroStingz suggestions.  Make a full Disk Image Back Up of your array.  Either Acronis or Macrium works great for this.  Validate the image (just takes a few extra minutes).  Try removing the drives and flashing using qFlash.  After flashing, reinstall the drives (same slots) and start the system.  Enter BIOS, Enable RAID and mark the m.2 as members.  See if it boots.  I have to be honest, the probability of success since this is RAID 0 is 1%. 

Now restore your previously created image to the array and post your results. 
Z390 AORUS PRO (F10) \850w, 9900K, 32GB GSkill TriZ RGB - 16-18-18-38, RTX 3080Ti FTW3 Ultra, 960 Pro_m.2, W10 21H2
Z370-HD3P (F5) \750w, 8350K, 8GB LPX 3200 - 16-18-18-38, GTX 970 FTW SC, Intel SSD, 2TB RAID1, W10 21H2
Z97X-UD5H \850w, 4790K, 32GB Vengeance, RTX 2080 FTW

autotech

  • 1553
  • 35
Re: GA-Z170X-Gaming 7 (rev. 1.0) BIOS
« Reply #3 on: August 24, 2017, 10:44:43 pm »
When you go into bios and build your array for raid 0 you will lose it period and a warning comes up that tells you all information on drives will be lose. As shadow says make a back up and then after upgrading just install back up. It isn't that hard and you should be up and running in less than an hour, Depending how much information you have on drives.
GA-Z170X-UD5,Core i5-6600K,16 GIG,3200 ram ,2 X Corsair 240GB SATA III SSD, 500 gig HD,7 ult 64\, Rx-480 8gig\

Z97X-SOC GIGABYTE, I5 4670k, 16 gig 1600 ram, 240 gig sata3 SSD,1x 500HD/ R9 280x, corsair 650 RM PSU

GA-Z97X-Gaming G1,850 corsair,,DDR4 3200,240SSd,6950 video,850EVA

 

anything