Official GIGABYTE Forum

Ryzen 1700X and AX370 K7: Memory too fast and CPU too slow - or vice versa.

Hi guys, first post here, I've been building PCs for over 20 years, but I need some advice!

I need help this time because I think I've reached the limit of trial and error  (and google) now that I've logged 30 hours (tinkering, not counting stress tests etc) on it. This is why it's quite a long post, I do apologise.

I've searched the forums and found the usual 'can't get RAM up to speed etc', but I appear to be having the opposite problem.

So this build is a special one, because it is my first for myself. Over the last 20 years I've built literally hundreds of high end workstations, servers, gaming PCs and even bespoke kiosk appliances. I've only ever 'made do' and upgraded what bits I had laying around at the time.

This time my other half convinced me to just go ahead an buy some parts. I gave myself a budget of £2000.

I did A LOT of research and thought I'd made the best decision buying the 1700X over the 1800X and the AX370 K7 over the Asus Crosshair X370.

So I knew about some of the memory issues with Ryzen before I got into this, which is why I bought the highest density I could afford while keeping in the range of the most over-engineered. Corsair Dominator Platinum 32GB (2x16) C15.

Last I checked this wasn't on the QVL, but it is in fact just a higher quality version of what is on the list.

Here is my build:

PSU: Corsair TX750
Motherboard: Gigabyte Aorus AX370 K7 - F7a Firmware
Processor: Ryzen 1700X at 3.8GHz (more of this later)
Cooler: CoolerMaster MasterLiquid 240
RAM: Corsair Dominator Platinum 32GB (2x16) C15
GPU: Gigabyte Aorus GTX 1080Ti (bought this a week after initial build)

The rig draws roughly 290w in normal (few VMs etc) use and around 500-600w when working hard.

I feel I need to fill you in on the story so far:

I built the machine and it booted first time with stock settings, I installed drivers etc and gave it a quick benchmark with a few tools Prime95, PassMark, CineBench, PCMark, SiSandra 3DMark, Heaven, CPU-Z etc. The CPU is in the 99th percentile - great stuff. The memory is in the ~54th percentile - not good, but still stock.

So now I get to tuning. I want a light overclock on the CPU, so we start with this. Moving from 3.8Ghz to 4.0Ghz was no biggy. Temps all under 50 and power delivery temps were great under load. Super, I'll probably not push on more than that.

VCore is at 1.35v (recommended max by AMD)
SOC is at 1.25v (recommendations from builds I've read about online)
CPU LLC is on Turbo or Extreme - both are about the same in testing.



I set the machine away stress testing overnight and came back to perfect a perfect MemTest with no errors. 2GB on each thread, using all 32 GB RAM. Temps stayed under 54, even the VRM.

Ok, great stuff, EASIEST BUILD EVER. Spoke too soon.

The next 27 hours would be spend fiddling trying to get the ram to work correctly, and balancing this with a stable OC.

So... my problem:

Using the supported voltage of 1.35v...

The machine is stable at stock. 3.4Ghz and 2133Mhz (I should say that 'stock' means 2133 on the memory, as applying the XMP at stock doesn't work)

I can get a stable 'OC' at 3.8GHz (not really OC as that's the rated boost frequency) with the memory at 3066, but not 2933.

I can get an 'unstable' OC at 4.0Ghz and 2800 on the memory. (It was rock solid for like 5 hours of testing, and got the highest benchmark scores so far, by a large margin: ~11000 in Time Spy and 23000 in Firestrike) But in the morning the BIOS reset as it didn't like the settings.

I can get a fully stable system at 3.7GHz and 3600 or 4132 on the memory. MemTest passes with flying colours overnight.

I can't overclock and have stable memory at anything other than stock or 3066. I know both the CPU and memory go faster, so how can I have my cake and eat it?


Is it a memory controller issue? I thought Ryzen craved faster memory? Or is it weak cores on the 1700X? - This doesn't seem likely as it's been stressed at 4.0GHz for roughly 24 hours without skipping a beat. I'm a bit perplexed as it looks like the CPU can't handle the high throughput of higher frequency memory, which is odd as it was one of the main selling points of Ryzen.

This new platform has me a little out of my depth, and if I didn't shave my head, I'd be pulling my hair out. It seems a lot more arcane than building the old FX series or the new Intel stuff.

When it finds settings it doesn't like, it does the normal pre-post test with 3 or 4 resets, then attempts to post and resets the bios. Then it'll boot first time.

I've tried rebuilding and reseating everything, made sure power delivery is adequate. Changed DIMM slots, used single DIMMs. Tried without GPU, tried a different GPU, no GPU (and gone off the diagnostic display). Updated the firmware, switched to 2nd bios and used older firmware. Used XMP, used manual timings and settings. Set values in the Gigabyte EasyTune software. Tried the OC button on the motherboard (doesn't work - BIOS also doesn't have the EZOC button).
Tried looser timings, tighter timings, odd timings, even timings.

I can confirm, that individually all of the parts perform fantastically. The DDR4 in a friend's Intel build let you use them at 3200, which is what I had wanted from the get go. I understand that neither the density nor rank of the memory is currently supported, but as it is the flagship of the leading memory brand, I'd hope for better results. Not only that, but it's been quite a while since the Ryzen platform released with these issues.

Sorry for the long post. I'm out of options at this point. My rig is by no means slow, I just want to have the performance that I know this rig should have.

Many thanks in advance.
« Last Edit: October 16, 2017, 12:25:25 pm by Total Liability »

 

anything