Official GIGABYTE Forum

RGB Fusion not working?

RGB Fusion not working?
« on: November 15, 2017, 05:21:31 pm »

I am pretty new to the PC building world, and I've only just got round to building my new PC.

I've got an Aorus Gaming 7 (z370), and up to there everything is working fine. PC boots up,works great, etc.

So my only current problem is, I can't install RGB Fusion in any shape or form?

I've followed the instructions, downloaded App Center from the motherboards support website. Then, I have tried both installing RGB Fusion separately and I also tried doing it when it appeared in the 'NEW' section on App Center.

My problem is, there is absolutely zero sign of RGB Fusion existing within my PC.

My App Center also looks completely different to all the ones I have seen on Youtube (big window). Mine just seems to be a minimized App Center near my clock.

Anyone got any ideas?

Re: RGB Fusion not working?
« Reply #1 on: November 15, 2017, 05:31:00 pm »
Little update. RGB Fusion seems to be installed (all the files are in C/Program Files/ Gigabyte , I just can't seem to find any way of accessing it!


  • 2205
  • 66
  • Xbox One, Drives STI, Use QVL RAM For Best Results
    • Gigabyte US
Re: RGB Fusion not working?
« Reply #2 on: November 17, 2017, 12:19:22 am »
You should be able to launch the RGB Fusion App from within App Center.  You need to use the Live Update within App Center to populate and update the list of apps available to run. 
« Last Edit: November 17, 2017, 01:18:37 am by shadowsports »
Z390 AORUS PRO (F10) \850w, 9900K, 32GB GSkill TriZ RGB - 16-18-18-38, RTX 3080Ti FTW3 Ultra, 960 Pro_m.2, W10 21H2
Z370-HD3P (F5) \750w, 8350K, 8GB LPX 3200 - 16-18-18-38, GTX 970 FTW SC, Intel SSD, 2TB RAID1, W10 21H2
Z97X-UD5H \850w, 4790K, 32GB Vengeance, RTX 2080 FTW


  • 3
  • 0
  • Hey how it's going?
    • Xtremegaminerd
Re: RGB Fusion not working?
« Reply #3 on: November 19, 2017, 03:00:08 pm »
It happened to me also when I for the first time used the Aorus X370 Gaming 5 motherboard. I don't remember how I fixed it but I think what I remember is that I installed the software again.