Official GIGABYTE Forum

GA-EP31-DS3L rev 1.0 with 4GB of Corsair PC8500C5 RAM.... problem!

Vista wont or doesnt seem to utilise my full 4GB of 1066MHz RAM but only uses 2GB.

In task manager in Vista the performance tab states i have:

Physical memory
Total         2046
Cached     1118
Free            337

Is there something im supposed to check/uncheck to make vista use all the 4GB?
I only ask because Vista system properties clearly states 4.00GB of RAM and CPUz150 also reports the full 4096MB of RAM and also shows the slots 0,3 both have a 2024MB module in there.

I decided to mess around and see if i could get it to work:

I tried re-seating the RAM in a few different configurations (ALL LISTED in motherboard manual as possible config's for ram) and i also tried a single stick start up with both of the new 2GB rams and they worked ok.In fact all but one configuration booted up ok.
(info: Dimm0,Dimm1 are bank0 and Dimm2,Dimm3 are bank1, Dual mode needs one stick in bank0 and one in bank1 according to manual)

the configurations i used were:

1X2GB in Dimm0 + 1X2GB in Dimm2 ... result boot ok vista and CPUz see's 4.00GB
1x2GB in Dimm1 + 1x2GB in Dimm3 ... result boot ok vista and CPUz see's 4.00GB
1x2GB in Dimm0 + 1X2GB in Dimm3 ... result boot ok vista and CPUz see's 4.00GB
1x2GB in Dimm1 + 1x2GB in Dimm2 ... result wouldnt boot and kept reseting before bios screen

also tried:

1x2GB in Dimm0 ... result boot ok vista and CPUz see's 2.00GB

then again i tried the other stick and it worked ok too(same exactly in fact) hinting that both modules of RAM work ok alone


I currently have it set up with 1x2GB in Dimm0 + 1X2GB in Dimm3 and i double checked the manual to be sure this was listed as ok and it is.


So im now a bit stuck, there doesnt seem to be a single module thats not working but rather that Vista itself refuses to utilise any more than the 2046MB stated in the task manager performance tab. Likewise all the Dimm sockets appear to work ok except perhaps Dimm2 in the final configuration (this is why i used the Dimm0,Dimm3 recommended placement.

This seems to be a Vista software problem or perhaps I need a newer bios update? but even this seems weird considering i have Vista service pack 1 and latest updates plus I updated my Bios to the latest one not a few months back so i doubt there will be newer versions yet.(i think my bios is F4 version)


can anyone please help? I dont really know where to go next. I tried looking at corsairs lab tests and they dont have a test for the GA-P31-DS3L but they do have the GA-P35-DS3L with these modules and it seems to be compatible.


Can you help me please gigabyte as i cant seem to find anyone on the tech help forums who has a same/similar setup and Im stuck now with a wasted purchase:(

thnks all


Re: GA-EP31-DS3L rev 1.0 with 4GB of Corsair PC8500C5 RAM.... problem!
« Reply #1 on: April 25, 2009, 08:25:09 pm »
This board doesn't support 4 sticks.

It'll support 4GB kids that are made up of 2x2GB sticks in dual channel mode.

There is a way to utilise past 4GB in the advanced section of the BIOS (press F4 I think) but either way, it'll not be happy once all slots are filled.

Best results are with 1+3 (1,2,3,4)

It's an old issue, but I don't ever recall there being a way round it.

To double check it's all there, do the following:
1). R.hand click on "My Computer" and select "Properties". A new window will open listing you're PC's key hardware (CPU model, speed, ammount of RAM and version of Windows)

2). Download "CPUZ" and run that. Go to the Memory tab and you can look at all the slots individually. It'll list what RAM, if any, is being regitered in each slot as well as give you further information on them (speeds, voltages etc)

There is a 3rd, and that's what version of Windows do you have? If it's a 32bit OS then it can't see more than 4GB in total, that includes GPU RAM, BIOS, Page file, Network Cards and any other cards you have that have built in RAM. The average system will only ever see ~3.4GB due to a 512MB GPU, Page file and BIOS. The only way it'll see further is if you use a 64bit OS. (only Vista / 7 64bit is recommended, I mean, c'mon, Windows Live messenger made by Microsoft doesn't even support XP 64bit - I'm having to run aMSN open source ;D)

Hope that information is enough to help!

~Bex

 

anything