Official GIGABYTE Forum

8 months of being messed around by Gigabyte Support

8 months of being messed around by Gigabyte Support
« on: April 19, 2018, 08:12:09 pm »
Hello,

For the last 8 months I have had nothing but utter rubbish replies from Gigaybte support UK. Starting to think they do not even read my messages. It has been to the service centre 3 times now.

I bought a Gigabyte P37 laptop a couple of years ago. All was well until 8 months ago my game would freeze for around 5-10 seconds with the sound making a garbled noise like the machine had completely froze. This would go back to normal but the sound would then be extremely quiet even at full volume. Around 30-40 mins later the same thing would happen but after it the sound would be back to normal again. When checking temps the CPU was reaching 95-97 degrees celsius.

I tried a cooling pad and everything but no change in temperature. This is happening in nearly every game I try from Pub G to Escape from Tarkov to Skyrim.

I contacted the support center who asked me to send it back which I have done 3 times now.

 First the Thermal pads were changed, then the thermal paste and this time it has had a motherboard replacement.

At one point they told me it was drivers as I had new drivers installed and I was baffled to be told to revert to the drivers on their website dating back to 2015 but I still did it but obviously this did not affect temperature.

I am at my wits end. I have asked for a complaints or head office department on several occasions and this has been completely ignored every time and the only response they can give is send it back to the centre. See below

http://tinypic.com/r/107uwiq/9

8 months surely is not acceptable. Anyone got any ideas what the issue could be or can point me in the right direction where I can contact head office or complaints department?

I have already lodged a complaint with the financial ombudsman and I am awaiting a response.


 

anything