Official GIGABYTE Forum

RX570 Issues

Smokie

  • 1
  • 0
RX570 Issues
« on: July 10, 2018, 10:47:15 am »
Hi everyone,

I just joined and hoping some experienced forum members might be able to help me with the situation I am in.
I built two machines for the kids at Christmas, Both identical machines except for the GPU's.
MSI B350 Tomahawk mothrboards, Ryzen 3 Cpu's and bot with 8Gig of Ram.

One machine has the Gigabyte Gaming RX570 4gb and the other has the Nvidia GTX 1050 TI by Strix.

My guess was that the RX570 is a better card? but the results dont appear that way. Fortnight on the RX570 looks terrible on the playable settings, I guessed it should max it out like the 1050ti but it cant.

I ran the Heaven benchmark and am getting an average 13fps compared to the 1050ti's 60fps. Something is not right im guessing, I have tried drivers and other bits and pieces but it still has issues.

I installed Injustice 2 last night on both machines, and initially the game told me it could not be played on the lowest settings, I put the card into OC mode and its now getting 30-50 fps.

What kind of settings can this card put out in anyone's experience?  I have seen youtube videos of it performing great at 1080p and even low 30 fps at 1440p

Thanks in advance

AgentFXA

  • 340
  • 10
Re: RX570 Issues
« Reply #1 on: August 02, 2018, 10:27:43 am »
I have here a Gigabyte RX 570 (see attachment) and gaming in 4k display mode is no problem at all - FC4 and GRW (Ghost Recon Wildlands) run perfectly smooth.

I suggest you run the 3DMark Skydiver benchmark to see what's its score - mine is 20,020 in 4K mode. Anything much lower and you gotta problem.. btw my machine is not OC'ed in any way.


« Last Edit: August 02, 2018, 10:28:34 am by AgentFXA »
GA-990FXA-UD3v4.0 / FX-8320 / GV-RX570AORUS-4GD / 24GB HyperX Fury 1866  / SeaSonic 650W / Thermaltake Armor MX / Win10x64