Official GIGABYTE Forum

H370: LAN cant connect

H370: LAN cant connect
« on: February 08, 2019, 10:30:25 pm »
Hi guys, I've got a new PC with a Gigabyte H370 MB which has an onboard Intel NIC 1219-V.

I have it plugged in and can see connection light and flashing (activity) but within the BIOS it shows "Link Status - Disconnected".

I've tried different cables and tested it on a laptop which worked fine.

I have HyperV 2012 installed and it too cannot see the LAN.

No matter what I do I cannot get it "Connected".

I have updated the BIOS to the latest version too.

If I plug in a PCIe NIC, it works, so no idea why the onboard NIC wont work.

Any ideas/suggestions?


  • 1938
  • 60
  • Xbox One, Drives STI, Use QVL RAM For Best Results
    • Gigabyte US
Re: H370: LAN cant connect
« Reply #1 on: February 10, 2019, 05:31:48 pm »
LAN connectivity doesn't show in BIOS or work in the host OS:

What are you connecting the port to?  Router (DCHP Server).  Believe you said another device works with it?

-Try with a different cable (already done)
-Reset BIOS, perform a CLR_CMOS and retest with defaults
-While troubleshooting, do not attempt to reserve an IP based on MAC address on the device providing DHCP

NIC shows LED connectivity but fails to negotiate connection  If DHCP is working properly on the network, sounds like the port.

Since the failure occurs at the BIOS level, without OS or driver involved, I would not expect a different driver would help.  The NIC supports 10/100/1000.  If other devices are working as expected, it's likely the port is bad.

Z390 AORUS PRO (F10) \850w, 9900K, 32GB GSkill TriZ RGB - 16-18-18-38, RTX 2080 FTW3 Ultra, 960 Pro_m.2, W10 1909
Z370-HD3P (F5) \750w, 8350K, 8GB LPX 3200 - 16-18-18-38, GTX 970 FTW SC, Intel SSD, 2TB RAID1, W10 1909
Z97X-UD5H \850w, 4790K, 16GB Vengeance, GTX 970 FTW SC, RAID0