Official GIGABYTE Forum

GIGABYTE GeForce GTX 1070 Xtreme Gaming - BIOS issue

wokie

  • 2
  • 0
GIGABYTE GeForce GTX 1070 Xtreme Gaming - BIOS issue
« on: September 25, 2019, 03:20:55 pm »
Dear all,

 Hope you can help me here. I have recently downloaded latest BIOS F3 from Gigabyte website and tried to update my card (GIGABYTE GeForce GTX 1070 Xtreme Gaming). Well the result was that I had a black screen. I know, "Don't fix it if it works" but well...it happened. So I have tried to download GV-N1070XTREME-8GD/F2/0404 from techpowerup web site which partially fixed the issue. First time when I power on my computer I get black screen again, but if I reboot my computer then it loads normally. The problem is that from time to time some application crashes now and the performance is not same like it used to be. And also rebooting computer anytime when I want to start it is quite annoying. When I contact Gigabyte support I was told that my stock BIOS was in fact F10 so flashing it with F3 caused the damage. Is there any owner of the same gpu who could provide me with his/her stock BIOS or backup of their F10 BIOS for this graphic card?

Thank you,

Regards,

Tomas

shadowsports

  • 1776
  • 53
  • Xbox One, Drives STI, Use QVL RAM For Best Results
    • Gigabyte US
Re: GIGABYTE GeForce GTX 1070 Xtreme Gaming - BIOS issue
« Reply #1 on: September 25, 2019, 06:46:55 pm »
I see 2 versions v1, v2 of this card.  Which do you have? 
Z390 AORUS PRO (F10) \850w, 9900K, 32GB GSkill TriZ RGB - 16-18-18-38, RTX 2080 FTW3 Ultra, 960 Pro_m.2, W10 1903
Z370-HD3P (F5) \750w, 8350K, 8GB LPX 3200 - 16-18-18-38, GTX 970 FTW SC, Intel SSD, 2TB RAID1, W10 1903
Z97X-UD5H \850w, 4790K, 16GB Vengeance, GTX 970 FTW SC, RAID0

wokie

  • 2
  • 0
Re: GIGABYTE GeForce GTX 1070 Xtreme Gaming - BIOS issue
« Reply #2 on: October 03, 2019, 10:49:45 am »
V1 version

 

anything