Official GIGABYTE Forum

FI27Q-P and Xbox one X

FI27Q-P and Xbox one X
« on: January 24, 2020, 04:29:49 pm »
Hi, I recently got the FI27Q-P but I am having a few issues with it when connecting to my Xbox one x.

I currently can’t seem to get it to run at 1440p at 120hz and have FreeSync enabled. 120hz works without FreeSync or 60hz with FreeSync. I have tried both ports and an ultra speed HDMI cable.

I haven’t been able to find much info about the monitor because it’s so new but I read that other people were having similar issues with their AD27QD but they seem to have got it working after a firmware update. The monitors are very similar so I would have thought if it worked on that one it would work on mine as they are so similar. It’s newer too so I would expect the firmware (I’m on latest) would have already had any fixes applied?
Does anybody know if it should be possible to get 1440p@120hz with VRR?

HDR also wasn’t working on the Xbox but I reset the EDID on it and now that works fine, but if I uncheck 4k it doesn’t let me set it again and I have to reset the Xbox again.

Another issue I am having is that certain colour tones have a kind of dotted grid that covers them, it only seems to be a small band of colour tones that are effected but it’s really annoying. Originally I was having the issue at 120hz and 60hz didn’t show it but now I can’t seem to get rid of it at all. I have tried all the colour settings on Xbox and monitor and nothing seems to help. I don’t see the issue when connected to my laptop over DisplayPort...

Hopefully somebody knows how to resolve these. If freesync just isn’t possible on HDMI 2.0 at 120hz then fine, but curious how others seem to get it working.