Official GIGABYTE Forum

A520 Aorus Elite - USB keyboard/mouse lags

A520 Aorus Elite - USB keyboard/mouse lags
« on: November 13, 2020, 05:06:10 pm »
Hello,

I have a problem with USB ports on Aorus Elite A520 motherboard. When I plug the keyboard to any USB 2.0 on back panel of MB then keybard is stuttering, laggy or repating and it's even worse with wireless keyboard and mouse. The USB 2.0 ports are internally connected as hub. In all other USB ports (3.x) keyboard acts properly, but when i tried to plug my wireless keyboard and mouse to USB 3.2 port on the top, then it was unusable. The signal is lost at a distance of 30 centimeters! WTF? When I boot Ubuntu Live distro then everything works. I contacted Gigabyte support, but that wasn't very helpfull. They said I should contact my dealer.. I already install all updates, latest BIOS and evertyhing is stock. I solved it by connecting the keyboard to the front panel. But this doesn't solve the fact that there is something wrong with the motherboard.

I read about similar issues with B550 Aorus Pro on this forum and also on other forums. Does GB messed up these motherboards?

HW:
Gigabyte Aorus Elite A520
AMD Ryzen 5 3600
Patriot Viper 4 2x 8GB 3200 MHz
AMD HD5850
Kingstone A2000 NVMe 250GB
500 W

shadowsports

  • 1972
  • 63
  • Xbox One, Drives STI, Use QVL RAM For Best Results
    • Gigabyte US
Re: A520 Aorus Elite - USB keyboard/mouse lags
« Reply #1 on: November 18, 2020, 02:48:23 pm »
Greetings,
I'm not completely clear what is working and what isn't.

Lag and stutter occurs under what OS?

But works as expected when you boot from a linux live CD?

This would indicate a software problem, not hardware.

Could it have something to do with your case? (that's not specified so not sure what headers it has connections for).

Signal is lost at a distance beyond 30cm...

I'd stick with one piece of hardware (keyboard type) while you are troubleshooting.

What happens when you enter BIOS with a wired keyboard and mouse?

Do they work?

Maybe try disconnecting everything from the case, except power connections and see what the behavior is.  Rule out what works with the USB 2.0 ports and what doesn't. 

Performing a CLR_CMOS might also be a good idea for testing.

You are introducing too many variables for an accurate problem description or diagnosis.     

Start over, control your environment and take notes.

 

« Last Edit: November 18, 2020, 03:21:20 pm by shadowsports »
Z390 AORUS PRO (F10) \850w, 9900K, 32GB GSkill TriZ RGB - 16-18-18-38, RTX 2080 FTW3 Ultra, 960 Pro_m.2, W10 2004
Z370-HD3P (F5) \750w, 8350K, 8GB LPX 3200 - 16-18-18-38, GTX 970 FTW SC, Intel SSD, 2TB RAID1, W10 2004
Z97X-UD5H \850w, 4790K, 16GB Vengeance, GTX 970 FTW SC, RAID0

 

anything