Official GIGABYTE Forum

Can't disable CSM / Gigabyte X99-UD4

Can't disable CSM / Gigabyte X99-UD4
« on: November 23, 2020, 08:29:48 am »
Hello everybody,

I recently upgraded to a new RTX 3070 and noticed a few more beeping sounds at the startup of the system. After a quick search, I learned this is probably due to CSM in the BIOS.
This turned out to be true, so I made sure I have Windows 10 in GPT and disabled CSM in the BIOS.
However, after saving settings, the system will do a cold reboot and set the setting back to "Enabled".

I thought, maybe the BIOS on my card doesn't support UEFI-GOP for some reason, but I couldn't disable CSM on my old 1070 as well.

Can you help me with this?

Rest of my system:
Gigabyte X99-UD4
4 x 4 GB DDR4 2133 MHz
PNY RTX 3070
Win 10 64 Bit

shadowsports

  • 2018
  • 63
  • Xbox One, Drives STI, Use QVL RAM For Best Results
    • Gigabyte US
Re: Can't disable CSM / Gigabyte X99-UD4
« Reply #1 on: November 23, 2020, 02:13:32 pm »
Greetings,
X99 - A oldie but goodie.

Your card and a boot drive formatted GPT should support UEFI / Secure boot and should allow you to disable CSM.

Pay attention to these BIOS options:

Windows 8 Features

Allows you to select the operating system to be installed. (Default: Other OS) & CSM Support
Enables or disables UEFI CSM (Compatibility Support Module) to support a legacy PC boot process.

Enabled Enables UEFI CSM. (Default)
Disabled Disables UEFI CSM and supports UEFI BIOS boot process only.

This item is configurable only when Windows 8 Features is set to Windows 8

Boot Order > Select Windows Boot Manager (if available)

or

Might you have something else installed that requires legacy boot support?



Z390 AORUS PRO (F10) \850w, 9900K, 32GB GSkill TriZ RGB - 16-18-18-38, RTX 2080 FTW3 Ultra, 960 Pro_m.2, W10 2004
Z370-HD3P (F5) \750w, 8350K, 8GB LPX 3200 - 16-18-18-38, GTX 970 FTW SC, Intel SSD, 2TB RAID1, W10 2004
Z97X-UD5H \850w, 4790K, 16GB Vengeance, GTX 970 FTW SC, RAID0

 

anything