Official GIGABYTE Forum

Z590M - can't get Wake on LAN working

Fred2k

  • 4
  • 0
Z590M - can't get Wake on LAN working
« on: October 20, 2021, 05:30:39 pm »
I have a Z590M, and am trying to get Wake on LAN working.

I have the Wake on LAN setting enabled in UEFI, and I've tried it with the ErP both enabled & disabled.

I have also tried numerous power related settings in Windows 10, so far with no joy.

Anyone know how to get this working please?

shadowsports

  • 2166
  • 65
  • Xbox One, Drives STI, Use QVL RAM For Best Results
    • Gigabyte US
Re: Z590M - can't get Wake on LAN working
« Reply #1 on: October 21, 2021, 05:19:24 pm »
I have a Z590M, and am trying to get Wake on LAN working.

I have the Wake on LAN setting enabled in UEFI, and I've tried it with the ErP both enabled & disabled.

I have also tried numerous power related settings in Windows 10, so far with no joy.

Anyone know how to get this working please?

Greetings,
Do you have a static IP set for the PC?

If you have the feature enabled and are certain the NIC is remaining powered, the next place to look is at the router or switch. 

Are you sure that device is passing wake packets to the correct IP?
Z390 AORUS PRO (F10) \850w, 9900K, 32GB GSkill TriZ RGB - 16-18-18-38, RTX 2080 FTW3 Ultra, 960 Pro_m.2, W10 21H2
Z370-HD3P (F5) \750w, 8350K, 8GB LPX 3200 - 16-18-18-38, GTX 970 FTW SC, Intel SSD, 2TB RAID1, W10 21H2
Z97X-UD5H \850w, 4790K, 32GB Vengeance, GTX 970 FTW SC, RAID0

Fred2k

  • 4
  • 0
Re: Z590M - can't get Wake on LAN working
« Reply #2 on: October 22, 2021, 05:05:20 pm »
Thanks for the response.

The IP is assigned via DHCP, but it is reserved so wouldn't change... but in any case I thought Wake on LAN used MAC addresses for sending the magic packets (at least in the Solar Winds app I'm using).

The NIC Link light actually goes off after Windows 10 is shutdown - I've spent hours trying to find the setting to stop this happening - however this isn't necessarily the only issue because if I turn power off at the PSU, then back on again the link light does come on, but Wake on LAN still won't work!

I don't think it's the switch, because I have 6 other PCs connected to the same switch and they all work fine with WoL.

shadowsports

  • 2166
  • 65
  • Xbox One, Drives STI, Use QVL RAM For Best Results
    • Gigabyte US
Re: Z590M - can't get Wake on LAN working
« Reply #3 on: October 23, 2021, 12:35:21 pm »
Greetings,
WoL is enabled by default in the BIOS.

What brand/model is your PSU?

Another place to check settings.

Device Manager > Network Adapters, expand.

Now right-click on your NIC and select properties.  Then the Advanced tab.  Look for setting called Wake on Magic Packet (or equivlent) and ensure its set to enable. 

Z390 AORUS PRO (F10) \850w, 9900K, 32GB GSkill TriZ RGB - 16-18-18-38, RTX 2080 FTW3 Ultra, 960 Pro_m.2, W10 21H2
Z370-HD3P (F5) \750w, 8350K, 8GB LPX 3200 - 16-18-18-38, GTX 970 FTW SC, Intel SSD, 2TB RAID1, W10 21H2
Z97X-UD5H \850w, 4790K, 32GB Vengeance, GTX 970 FTW SC, RAID0

Fred2k

  • 4
  • 0
Re: Z590M - can't get Wake on LAN working
« Reply #4 on: October 24, 2021, 12:02:23 pm »
I have checked the Network Adapter settings, can see Wake on LAN is enabled from Power Mgmt tab, and also in the Advanced tab.

PSU is a Corsair CV Series 550W 80+ Bronze

Fred2k

  • 4
  • 0
Re: Z590M - can't get Wake on LAN working
« Reply #5 on: October 24, 2021, 01:32:50 pm »
...Finally got it working!

In case it helps anyone else, seems to be a combination of the following:

BIOS - WoL enabled, and ErP disabled
Windows - Disabling Fast Startup from Windows power settings, and making sure WoL is enabled from Device mgr > NIC > Power management

shadowsports

  • 2166
  • 65
  • Xbox One, Drives STI, Use QVL RAM For Best Results
    • Gigabyte US
Re: Z590M - can't get Wake on LAN working
« Reply #6 on: October 25, 2021, 01:08:58 am »
Good job.

Fast start up is one of Microsoft's hybrid sleep variations. 

Have a beer, you earned it.   8)
Z390 AORUS PRO (F10) \850w, 9900K, 32GB GSkill TriZ RGB - 16-18-18-38, RTX 2080 FTW3 Ultra, 960 Pro_m.2, W10 21H2
Z370-HD3P (F5) \750w, 8350K, 8GB LPX 3200 - 16-18-18-38, GTX 970 FTW SC, Intel SSD, 2TB RAID1, W10 21H2
Z97X-UD5H \850w, 4790K, 32GB Vengeance, GTX 970 FTW SC, RAID0