Official GIGABYTE Forum

Problem with the M6900 mouse

Nabnut

  • 4
  • 0
Problem with the M6900 mouse
« on: June 19, 2011, 05:49:24 pm »
I recently bought the M6900 mouse and it appears to be broken, i am just curious if there is anyway to fix this. The dpi changer buttons are not working and the led for them is not lighting up, the 2 buttons on the side are also not working as well as the left and right tilt wheel. I have downloaded the driver and the firmware update from the gigabyte website and the mouse is still not working. Is there anything that can be done to fix this or is it simply just a bad mouse?

Dark Mantis

  • *
  • 18405
  • 414
  • 10typesofpeopleoneswhoknow binaryandoneswhodont
    • Dark Mantis
Re: Problem with the M6900 mouse
« Reply #1 on: June 19, 2011, 06:19:02 pm »
Hi

I know that the firmware does ned updating on these mice but if you have done that properly and it still isn't working I would have to assume that it is faulty. I take it that it is plugged into the I/O panel on the back of the motherboard not some other USB port ?
Gigabyte X58A-UD7
i7 920
Dominators 1600 x6 12GB
6970 2GB
HX850
256GB SSD, Sam 1TB, WDB320GB
Blu-Ray
HAF 932

Gigabyte Z68X-UD5-B3
i7 3770K
Vengeance 1600 16GB
6950 2GB
HCP1200W
Revo Drive x2, 1.5TB WDB RAID0
16x DLRW
StrikeX S7
Full water cooling
3 x 27" Iiy

Nabnut

  • 4
  • 0
Re: Problem with the M6900 mouse
« Reply #2 on: June 19, 2011, 06:19:30 pm »
Yeah its plugged in at the back

Dark Mantis

  • *
  • 18405
  • 414
  • 10typesofpeopleoneswhoknow binaryandoneswhodont
    • Dark Mantis
Re: Problem with the M6900 mouse
« Reply #3 on: June 19, 2011, 06:26:09 pm »
In that case I would return it for exchange at the retailer that supplied it.
Gigabyte X58A-UD7
i7 920
Dominators 1600 x6 12GB
6970 2GB
HX850
256GB SSD, Sam 1TB, WDB320GB
Blu-Ray
HAF 932

Gigabyte Z68X-UD5-B3
i7 3770K
Vengeance 1600 16GB
6950 2GB
HCP1200W
Revo Drive x2, 1.5TB WDB RAID0
16x DLRW
StrikeX S7
Full water cooling
3 x 27" Iiy

Nabnut

  • 4
  • 0
Re: Problem with the M6900 mouse
« Reply #4 on: June 19, 2011, 06:28:27 pm »
Thanks for the help hopefully I will have more luck with the next one 

Dark Mantis

  • *
  • 18405
  • 414
  • 10typesofpeopleoneswhoknow binaryandoneswhodont
    • Dark Mantis
Re: Problem with the M6900 mouse
« Reply #5 on: June 19, 2011, 06:31:18 pm »
Yes let's hope so. Again it will probably need the firmware updated to start with but after that should work well from what I have heard from other customers. Please let us know how you get on though. ;)
Gigabyte X58A-UD7
i7 920
Dominators 1600 x6 12GB
6970 2GB
HX850
256GB SSD, Sam 1TB, WDB320GB
Blu-Ray
HAF 932

Gigabyte Z68X-UD5-B3
i7 3770K
Vengeance 1600 16GB
6950 2GB
HCP1200W
Revo Drive x2, 1.5TB WDB RAID0
16x DLRW
StrikeX S7
Full water cooling
3 x 27" Iiy

Nabnut

  • 4
  • 0
Re: Problem with the M6900 mouse
« Reply #6 on: June 19, 2011, 06:40:23 pm »
will do

 

anything