Questions about GIGABYTE products > Motherboards with Intel processors

Can't Install Marvell 91xx Driver- GA-P55a-UD3

(1/3) > >>

Problem: Errors reported as no driver for Marvell 91xx.
Tried to install driver-failed.

See my signature for all HW info.
I don't think I am using the Marvell 91xx because my HDD config is NON-RAID with no ATA HDDs [only SATA HDDs].
Never-the-less Win7,utils & apps show a Marvell driver is missing error.

I downloaded the drivers for Marvell from I extracted & got Miniport/i386 and Storeport/i386 folders with Marvell drivers.  I pointed Win 7 at these drivers [one after the other]trying to install a Marvell driver from Windows' DEVICE MANAGER.  Windows says it cannot find either the drivers in either the miniport or storportfolders. This is essentially the same problem I encountered when I tried to use the drivers from the Gigabyte site.[see below]

PREVIOUSLY, in an earlier attempt to install Marvell drivers, I downloaded the 2 Marvel driver files from the Gigabyte Americas site.
First File:
motherboard_driver_marvell_console.exe   When this file is executed it creates a Marvell file in Program Files [x86]
One of the files it creates is driverinstall.exe. When I executed it it seemed to complete, but Device Manager still showed the YELLOW problem flag. When I tried to install the driver in Program Files/Marvel/M91xx/Console I received this ERROR message: Windows found driver software for your device but encountered an error while attempting to install it.
Second File:
marvell_91xx_1.2.0.1200_1.1.0.6( [Self uncompress]
Same problem as reported above. Windows can't find them.

Although this is a Windows 7 problem, I  also run Macintosh OSX 10.6.6 on the same PC [dual boot]. The OSX build uses a different non-RAID hard drive Samsung SATA 1TV 7200rpm. This Macintosh on a PC is called" OSX86" or "Hackintosh". OSX runs perfectly.The OSX build doesn't use RAID or ATA HDDs.

 Need Help:
1. Because I frequently get a "missing driver" error message from various utilities & applications, I would like to get the correct Marvell driver installed. When I do have any WIN 7 problems, all WIN diagnostics always point to missing driver as the cause even if that is unlikely.
2. If not, can I remove/disable/uninstall the Marvell 91xx ATA Device to get the same result?

Dark Mantis:
Hi  and welcome to the Gigabyte Forum.

The driver you require is available form the Gigabyte Download section.

If you are sure that you have nothing attached to the Marvell controlled ports then you could always disable it.

I'm sorry, I should have mentioned that I had tried to install those also. No luck.

The console driver from the Gigabyte site is an executable that seems to install. It creates a driversinstall.exe file. It puts that driversinstall.exe PLUS Marvell drivers in a new folder Program Files[x86]/Marvell. Even though driverinstall.exe doesn't display an error, the YELLOW warning STILL shows in DEVICE MANAGER for MARVELL. When I tried to manually install the driver via DEVICE MANAGER, I got a different error that was unhelpful.

The second driver file I downloaded from Gigabyte was a self extracting zip file. It extracted toMiniport & Storport folders same as before. I tried to install them too from DEVICE MANAGER. Windows couldn't find them???.

See my updated initial post for the details.

MAYBE IT IS A WINDOWS 64 vs. 32 bit issue. Programs that say they are for 64 FAIL with error messages that they are 32bit-wrong versions. The Windows Repair/Restore 64bit does that!

Aussie Allan:

  Without saying to much, the Marvell 9128 chip has been a disaster on many platforms including Gigabyte , and although I have not looked myself I have read several posts of people that are more comfortable with code then myself that state that.......... in the Marvell drive folder on Gigabytes site there is in fact no Marvell driver to be found , just a generic drivers that allows the connected drive/s to communicate with the system "through" the Marvell controller

 I myself had two weeks of frustration trying to get those two ports to perform as advertised,... My last attempt was a couple of Momentus XT 500gb Drives and the best I could get was a not toooooooo bad  212Mbp/s and the GUI interface just kept falling over.......... I could never get it to report a serial number back to the log which was mission critical for the Hybrid drives I was toying around with.

 Dark Matis's Advise is solid and sound ... SATAIII was/is the perfect marketing tool for generating revenue for all the R&D that is needed to mature these controllers to the level that intel (ICH10R) enjoy took them ten years!!!... hope this helps.

 Aussie Allan


--- Quote ---in the Marvell drive folder on Gigabytes site there is in fact no Marvell driver to be found , just a generic drivers that allows the connected drive/s to communicate with the system "through" the Marvell controller  
--- End quote ---
I thought I solved that by getting the drivers drirectly- but they seem to be the same ones that don't work for me.

Because there is no driver currently installed for the Marvell controller and everything SEEMS to work OK, is it reasonable to assume that disabling the Marvell won't break anything? At least for Windows 7.NOW

Am I correct that I only will need the Marvell controller if I need to connect to a 6Gb/s interface ? 

If so, does that mean the board will not connect to 6Gb/s drives except at 3Gb/s? I don't understand what is meant by ... communicate with the system 'through' the Marvell controller".
If I can not get either of the 2 drivers I downloaded from the Gigabyte site to install, does that mean I won't even be able to take advantage of connecting THROUGH the Marvell controller [whatever that means]?

One reason I bought the P55 was the 6Gb/s support, otherwise I would have bought an H55 board.

Thanks for your feedback


[0] Message Index

[#] Next page

Go to full version