Official GIGABYTE Forum

Completely disappointed.

Completely disappointed.
« on: August 04, 2011, 01:01:05 am »
Greetings all,

I have had quite a few issues with both my Gigabyte Motherboard and GPU.  I have always been an Asus fanboy, but when I upgraded from my AMD rig to an Intel Q9550, I decided to try Gigabyte due to all the positive feedback.  So, I shell out close to $500 US for a board, PSU, RAM, and CPU. I bought an EP45T-UD3LR. At first, everything was perfect. Then there was a BIOS update (F5 to F6) which claimed to fix some memory compatibility issues.  Being in the IT field I've always upgraded to the most current drivers and BIOS.  About a week after the BIOS upgrade, my PC started freezing randomly.

I RMA'ed my CPU. No fault found, shipping costs reimbursed. (Newegg rocks)
I RMA'ed my power supply. Company could not find a problem, but still gave me a brand new PSU anyways. (OCZ for the win!)
I RMA'ed my RAM (four sticks). Company did not make that RAM anymore and gave me a FREE upgrade to the most current. (GSkill rocks sometimes).
I bought a new CPU cooler because my temps were high. No fix.
I RMA'ed my hard drive. WD replaced the drive due to bad sectors and even did a data retrieval for free (they are nice to Military members).
I RMA'ed my RAM again because one stick died. GSkill sent me new RAM before I even had to send in the old stuff. Four new sticks, sequential S/N's!
I RMA'ed my motherboard. "No fault found." And it took them 3 weeks to mail it back.
I spent WEEKS researching, forum hopping, IRC hopping, GSkill tech support. Could not fix problem.
Upgraded BIOS again and again (F6 through F10).
I bought a new GPU. Gigabyte HD685OC. I figured I should match brands.

Now, this was an odd one. For the first month, I had ZERO issues. I was pleased. Then freezes started happening again.  Ran benchmarks for 3 weeks with 72 hour runs, could not duplicate issue, no problems. Only when casually using the PC it would freeze. Strange. More forum hopping. Then one day I got a BSOD claiming my GFX card drivers had failed. Called gigabyte tech support and they said it is probably a faulty card. I explained to them how it never BSOD'ed before.  I send in the new card.

I requested an e-mail or a phone call when they completed their testing. They never contacted me. I finally sent an e-mail to the RMA dept, to which they told me "No fault found" and they had already shipped it back. Odd I thought.  Whatever, maybe they are busy.  Graphics card gets back. Install it in my PC, boot it up, and BAM, BSOD before it finishes booting.  Same stop code, same driver.  Borrowed a friend's computer (AMD 1100T, Asus mobo), installed it in there, and it BSODs in his PC as well. I call up gigabyte and explain my frustrations in a professional manner. All I got back was "Well, you can RMA the card again if you feel there is still an issue. If we find no fault in the card, you may be charged $45 dollars."

Now, it has been 10 months of RMAs, troubleshooting, contacting multiple companies, borrowing PCs, RAM, GPUs, PSUs... I am not a happy camper.  I am a patient person, I give everyone the benefit of a doubt, and I never directly blame anyone if I'm not 100% sure.  I will say that I will never buy a Gigabyte product again and frustrated that I will not be able to return both the GPU and Mobo for a full refund.  I do not make a lot of money and can't afford to go buy yet another system.  I am disappointed that every time I called tech support, they had no drive to even try and troubleshoot with me over the phone. I got more support from OCZ's PSU department!  Your company failed to contact me upon request. Your delays with my motherboard were unacceptable since I was not contacted at all to say "We're sorry, we've been delayed a bit". Nothing!

As an IT professional, I NEVER stop trying to help my customers until their problem is 100% solved. I spend the extra couple minutes out of my day to call or shoot an e-mail to make sure they got 120% perfect service and support.  I don't expect everyone to do as much as I do, but I would expect a large corporation such as Gigabyte to at least put forth some effort.  My guess is this company is so big now they can afford to not care about the little guy.

Am I alone in my frustration? Am I right to be upset? Am I blowing this whole thing out of proportion?

Disappointed and frustrated,
Steve
United States Armed Forces

runn3R

  • *
  • 1328
  • 57
  • Admin
    • GIGABYTE UK
Re: Completely disappointed.
« Reply #1 on: August 04, 2011, 08:45:43 am »
Hi Steve

I'm sorry such situation happened. I will contact our USA branch to help you.
« Last Edit: August 04, 2011, 08:48:56 am by runn3R »
ZX-S & C64 are still my favourites ;-)

Re: Completely disappointed.
« Reply #2 on: August 04, 2011, 05:47:52 pm »
runn3R,

I appreciate you attempting to help, but at this point I have no interest.  The damage has been done.  I just wanted to get my complaint out there.  I am firm in my decision to never purchase from your company again and if anyone asks me how I feel about your products I will give them my experiences with this specific system.

Have a nice day,
Steve

 

anything