Official GIGABYTE Forum


« on: February 29, 2012, 07:28:04 am »

I posted up a problem to GTS, so far I have had no repsonse from them.
Is this the level of service from GTS, NOT to repsond to porblems?

The issue was:

I am trying to use a OCZ Vertex III 120GB SSD. NO RAID.

The motherboard has NOT been overclocked.

All bios settings are standard.

I have updated Bios(FH), and also using all updated drivers from Gigabyte website.

Firmware for the OCZ Vertex 120GB SSD is upto date:V2.15.

I have connected this to the SATA III port and run benchmarks using: AS SSD and Crystalmark.

I find that I am getting less than 1/2 the speed offered by the SSD.
Read is 267MB/s and Write is 158MB/s.

I have also connected to the SATA II port, and this has a similar result. So I can't even max the SATA II port.

Bios is set to AHCI. I have also tried other bios settings, which have made either no difference or made the benchmark result worse.

The SSD has been replaced for another, again same issue of speed.

I have tried both Optimized and Fail safe settings in bios also.

From what I have read on hte net, its all to do with the poor MARVEL controller?
Are there any fixes for this, if this is the case?


Dark Mantis

  • *
  • 18405
  • 414
  • 10typesofpeopleoneswhoknow binaryandoneswhodont
    • Dark Mantis
« Reply #1 on: February 29, 2012, 07:39:49 am »
Hi and welcome.

It would have been herlpful if you had given a few more details of your system especially the motherboard!

I would not advise yopu to keep running benchmark programs because SSDs don't like them.

I can't say why you haven't had a resp[onse from GGTS yet but it could be that they are very busy at the moment.

The problem is the Marvell 9128 controller chip doesn't live up to the hype. It is supposed to run at SATA3 6GBs throughput but it is not capable as things stand and the Intel ICH10R southbridge controller chip works better even though it is only SATA2 3GBs rated.  But at the moment that is the state of play.

Have you got any other drives attached tp the same controller on the motherboard ?

 I would suggest that you contact OCZ through their forums and see if they can explain the speed of the drive.
« Last Edit: February 29, 2012, 07:40:38 am by Dark Mantis »
Gigabyte X58A-UD7
i7 920
Dominators 1600 x6 12GB
6970 2GB
256GB SSD, Sam 1TB, WDB320GB
HAF 932

Gigabyte Z68X-UD5-B3
i7 3770K
Vengeance 1600 16GB
6950 2GB
Revo Drive x2, 1.5TB WDB RAID0
16x DLRW
StrikeX S7
Full water cooling
3 x 27" Iiy

« Reply #2 on: February 29, 2012, 05:03:53 pm »

The system is basically:

Gigabyte X58 UD3R Rev 2, Bios FH
Corsair 6GB DDR III 1800MHz Vegance
GPU MSI 6870
OCZ Vertex3 SSD 120GB, Firmware 2.15.
Windows 7 Ultimate.
Using all latest drivers from Gigabyte.

No other drives attached to the motherboard, I have tried the SSD on SATA II and SATA III ports, I can't even max out the SATA 2 port. The SSD has been checked by the vendor, and has also been replaced, The replaced SSD has the same benchmark values.

All the other reviews that I have read about the SSD, users have been able to achieve near the rated speed of the SSD, yet I am only getting speeds of READ: 263MB and WRITE of 159MB on the SATA III port. The SATA II port has even lower figures.

I ran benchmarks using AS SSD and Crystalmark, both have similar results.

From reading on the net everyones moaning about this Marvell controller and how poor it is. :'(

What I don't get is, surely the motherboard makes, Gigabyte, Asus etc must have "Proof " tested the spec of the boards not just yeah put the Marvell SATA III controller on the board its rated to 6GB, job done.  ;)

Too me this is like making a false claim on performance, clearly the board can't perform to claimed spec! >:(

Whats even more annoying is the lack of response from GTS. Yet my vendor says there GREAT  :D