Official GIGABYTE Forum

Gigabyte M6900 Optical Gaming Mouse problem

Gigabyte M6900 Optical Gaming Mouse problem
« on: June 20, 2012, 06:21:07 pm »
Hi, I recently purchased a Gigabyte M6900 Optical Gaming Mouse new from the package. However I have problems with it when gaming. In some games it works perfectly but in some there are problems. Sometimes the right click gets stuck and it feels weird when you have free-aim assigned to that click. It's the same with the left click, sometimes my shooting get stuck and my weapon just spam bullets. I have to click again to stop shooting. Does anyone know why? It works perfectly fine on other online games. I updated the mouse with the firmware update provided on the Gigabyte website and I also have the Utility for the mouse installed too.

Does anyone know what the problem is? :(

Thanks,

gundam2
« Last Edit: June 20, 2012, 06:24:22 pm by gundam2 »

Dark Mantis

  • *
  • 18413
  • 413
  • 10typesofpeopleoneswhoknow binaryandoneswhodont
    • Dark Mantis
Re: Gigabyte M6900 Optical Gaming Mouse problem
« Reply #1 on: June 21, 2012, 09:19:53 pm »
Hi,

I haven't heard of anyone else complaining of this particular problem so I would tend to think it is more likely down to the game in question. Make sure that you have downloaded and applied all the patches that are available.
Gigabyte X58A-UD7
i7 920
Dominators 1600 x6 12GB
6970 2GB
HX850
256GB SSD, Sam 1TB, WDB320GB
Blu-Ray
HAF 932

Gigabyte Z68X-UD5-B3
i7 3770K
Vengeance 1600 16GB
6950 2GB
HCP1200W
Revo Drive x2, 1.5TB WDB RAID0
16x DLRW
StrikeX S7
Full water cooling
3 x 27" Iiy

Re: Gigabyte M6900 Optical Gaming Mouse problem
« Reply #2 on: September 15, 2012, 08:09:04 am »
I recently started having this problem as well with the same mouse.  It was fine for a long time then it started to feel like my gun was on burst (like I was tap firing multiple times but with one tap) and it went onto blowing full clips randomly into walls because I couldn't get it to stop firing.  I thought it was because my mouse was a bit worn as I game a lot so I bought another one about a month ago, just plugged it in the other day and have the same exact problem.  I'm not sure what exactly changed to cause this to happen but I'm going to try a logitech mouse and see if I get the same results...if not, sorry gigabyte :(
« Last Edit: September 15, 2012, 08:09:43 am by iamunoriginal »

Dark Mantis

  • *
  • 18413
  • 413
  • 10typesofpeopleoneswhoknow binaryandoneswhodont
    • Dark Mantis
Re: Gigabyte M6900 Optical Gaming Mouse problem
« Reply #3 on: September 16, 2012, 06:45:59 pm »
Hi

It is almost certainly not the mouse itself but more likely the software/drivers. Also try just reboting as sometimes that is all that is required.
Gigabyte X58A-UD7
i7 920
Dominators 1600 x6 12GB
6970 2GB
HX850
256GB SSD, Sam 1TB, WDB320GB
Blu-Ray
HAF 932

Gigabyte Z68X-UD5-B3
i7 3770K
Vengeance 1600 16GB
6950 2GB
HCP1200W
Revo Drive x2, 1.5TB WDB RAID0
16x DLRW
StrikeX S7
Full water cooling
3 x 27" Iiy