Official GIGABYTE Forum

GA-Z77X-UD3H Can't boot from USB sticks?

GA-Z77X-UD3H Can't boot from USB sticks?
« on: July 21, 2012, 06:17:52 am »
I have several bootable USB sticks that work fine with older Gigabyte motherboards, such as the GA-X58A-UD3R. However, when I try to boot from them with my GA-Z77X-UD3H the BIOS completely ignores them. I have the current BIOS version, F11. To try to get this to work, I loaded the optimized default settings, and I also tried both USB 2 and USB 3 chipset ports. (The sticks are USB 2.) But the USB sticks don't appear in the boot priority settings or in the boot override list. The USB sticks and ports are working otherwise- they work fine with any OS that I boot. Is there some trick to booting USB sticks with this motherboard?


  • 1
  • 0
Re: GA-Z77X-UD3H Can't boot from USB sticks?
« Reply #1 on: August 01, 2012, 12:12:49 am »
I have the GA-Z77-D3H version, but I noted (maybe before I updated my BIOS to F14) that it wouldn't always recognize the USB key on boot if it were already plugged in (i.e., I would have to replug it and then reboot for it to appear in the boot list).

You may want to try:
1. Unplug the USB key
2. Reboot (or do a cold boot from power-off)
3. Enter the BIOS UI
4. Plug the USB key in
5. Exit the BIOS UI and see if the key is listed in the boot menu (F12 key)

I've also noticed that not all of my internal SATA drives are listed in the BIOS boot order list, but they do appear in the boot device selection list (F12 key).  ???


  • 39
  • 1
Re: GA-Z77X-UD3H Can't boot from USB sticks?
« Reply #2 on: August 03, 2012, 03:42:58 am »
rear usb ports--two belongs to intel controller. the other 4 usb ports belong to via chip. you may try to have ur usb drive on below Lan port.

Re: GA-Z77X-UD3H Can't boot from USB sticks?
« Reply #3 on: August 10, 2012, 05:43:07 pm »
I tried different rear ports, and actually found just the opposite. USB sticks show up and can be used for booting when they're in the rear VIA ports, but not when they're in the Z77 ports. That's a problem for me because I use USB  to install OS X, which works fine with the Z77 ports, but has no driver for VIA.