Official GIGABYTE Forum

970A-D3 AHCI

Movick

  • 4
  • 0
970A-D3 AHCI
« on: April 16, 2013, 10:37:58 am »
Hello,

  I have a 970A-D3 mobo/SSD (w/ SATA 3 cable), AMD 8120, 24GB RAM, Windows 7/64 - custom build.

I didn't do the build myself, but I'd like to try and straighten out an AHCI issue I'm having.

I originally had a dual-boot set-up on this mobo whereby a cloned mechanical drive was cabled to port 0 (active/boot files) and a small SSD was cabled to port 1. I also have a storage disc which is now cabled to port 1. Last night I removed the mechanical drive boot disc due to failure and I cloned my small SSD to a larger one. The SSD is now on port 0.

I will be doing a single-boot set-up from now on in Windows 7 with the SSD for the boot/O/S.

I believe my BIOS is properly set for AHCI, but when I check Device manager: IDE ATA/ATAPI Controllers, I do not see an AHCI device indicated. I located the msahci key in regedit and it is already set to "0." My BIOS "OnChip SATA type" is set to AHCI. I also verified that trim is enabled.

Is there a BIOS setting which needs to be changed to have windows properly recognize my boot SSD as AHCI?





Any assistance would be greatly appreciated!

Thanks in advance!
Movick

« Last Edit: April 16, 2013, 10:43:09 am by Movick »

Vezina

  • 871
  • 10
  • If it s not broken, fix it until it is !
Re: 970A-D3 AHCI
« Reply #1 on: April 16, 2013, 07:20:07 pm »
The AHCI switch is in BIOS.
Go in BIOS to Integrated peripherals and choose AHCI instead of IDE mode.

This is one guide how to make sure you boot properly after BIOS setting change,  one of the links google picked up ->  http://forums.guru3d.com/showthread.php?t=313676
Over & Out !

AMD FX (APU-s included) users should install - KB2645594 & KB2646060 under Windows 7

1.ASUS Sabertooth 990FX 2.0 + FX 6300 + H60
2.MSI A88X-G41 PC Mate + A8 5600K + Hyper TX 2
3.Gigabyte F2A75-D3H + A4 5300
4.ASUS AM1M-A + Athlon 5150

Movick

  • 4
  • 0
Re: 970A-D3 AHCI
« Reply #2 on: April 16, 2013, 10:01:56 pm »
Take a look at the BIOS screen-shot. As I stated the AHCI switch is set to AHCI under " OnChip SATA type" but it doesn't show up as AHCI in device manager. Moreover, I stated that I accessed the regedit key "msahci" as specified in the article - it already has a value of "0."
« Last Edit: April 16, 2013, 10:04:31 pm by Movick »

Vezina

  • 871
  • 10
  • If it s not broken, fix it until it is !
Re: 970A-D3 AHCI
« Reply #3 on: April 16, 2013, 10:11:45 pm »
Sorry ,i did not see the picture ,browser had some stuff disabled.

Set all ports to AHCI and look in Device Manager again .

After doing this post a picture with the Device Manager as well to see what devices show up in there exactly.

Are there any messages during post regarding  AHCI before OS boot ?!Usually when it s enabled you should see some AHCI device/BIOS messages when using non UEFI BIOS.
Over & Out !

AMD FX (APU-s included) users should install - KB2645594 & KB2646060 under Windows 7

1.ASUS Sabertooth 990FX 2.0 + FX 6300 + H60
2.MSI A88X-G41 PC Mate + A8 5600K + Hyper TX 2
3.Gigabyte F2A75-D3H + A4 5300
4.ASUS AM1M-A + Athlon 5150

Vezina

  • 871
  • 10
  • If it s not broken, fix it until it is !
Re: 970A-D3 AHCI
« Reply #4 on: April 16, 2013, 10:22:57 pm »

Nevermind!

In the second picture there is shown an "AMD SATA Controller" device
That s your AHCI right there .
If you want an AHCI AMD driver you can install it.On AMD website you can find a so called southbridge driver that includes it.

I can assure you i will punish my browser plug ins :)
Over & Out !

AMD FX (APU-s included) users should install - KB2645594 & KB2646060 under Windows 7

1.ASUS Sabertooth 990FX 2.0 + FX 6300 + H60
2.MSI A88X-G41 PC Mate + A8 5600K + Hyper TX 2
3.Gigabyte F2A75-D3H + A4 5300
4.ASUS AM1M-A + Athlon 5150

Movick

  • 4
  • 0
Re: 970A-D3 AHCI
« Reply #5 on: April 16, 2013, 10:24:57 pm »
So change SATA port 4/5 to AHCI?
Any other setting to AHCI as well?
"Are there any messages during post regarding  AHCI before OS boot?"

I don't see any messages about AHCI prior to loading the O/S.

Thanks BTW.
Movick
Whoops...I guess I "minded." ;)
« Last Edit: April 16, 2013, 10:26:18 pm by Movick »

Vezina

  • 871
  • 10
  • If it s not broken, fix it until it is !
Re: 970A-D3 AHCI
« Reply #6 on: April 16, 2013, 10:36:51 pm »
You are welcome ! :)

First time i did not see any picture ,second time only the first one showed up  ,but third time the relevant one uncovered itself :)

I recommend you to use a benchmarking tool and test the speed with both the Microsoft driver and the AMD one.
If the AMD one is slower you can very well revert to the Microsoft one afterwards.
Over & Out !

AMD FX (APU-s included) users should install - KB2645594 & KB2646060 under Windows 7

1.ASUS Sabertooth 990FX 2.0 + FX 6300 + H60
2.MSI A88X-G41 PC Mate + A8 5600K + Hyper TX 2
3.Gigabyte F2A75-D3H + A4 5300
4.ASUS AM1M-A + Athlon 5150

Movick

  • 4
  • 0
Re: 970A-D3 AHCI
« Reply #7 on: April 16, 2013, 11:03:19 pm »


W/ MS

I installed the Catalyst package using the installer - don't see the AMD AHCI driver updated - still MS. Anyone know how to install the AMD AHCI drivers?
« Last Edit: April 16, 2013, 11:40:06 pm by Movick »

Vezina

  • 871
  • 10
  • If it s not broken, fix it until it is !
Re: 970A-D3 AHCI
« Reply #8 on: April 17, 2013, 05:54:42 pm »
If the installer has the drivers ,but does not detect the AHCI controller maybe you should use the Gigabyte supplied driver.
Furthermore you can ask Gigabyte support for more info.
Over & Out !

AMD FX (APU-s included) users should install - KB2645594 & KB2646060 under Windows 7

1.ASUS Sabertooth 990FX 2.0 + FX 6300 + H60
2.MSI A88X-G41 PC Mate + A8 5600K + Hyper TX 2
3.Gigabyte F2A75-D3H + A4 5300
4.ASUS AM1M-A + Athlon 5150

 

anything