Official GIGABYTE Forum

BIOS boot setting unstable when Secure Boot set to off andUEFI OS selected

Hi,

I am struggling to make my P35X V3 laptop dual boot Linux and Windows 8.1 nicely. At the moment, every time I want to change OS, I have to edit the BIOS settings. I realise that you don't actively support Linux but I believe that this is a problem with the BIOS.

I have disabled Secure Boot by clearing the 'Factory Keys' which seems to leave it disabled in setup mode. The Windows 7/Windows 8 settings only seem to clear or install the factory keys and set the OS to UEFI with secure boot or Legacy OS with secure boot disabled. (Could you clarify if there is more to these settings than can be seen in the BIOS?).

I have Debian installed as UEFI and Windows 8.1. I would just like to be able to press F12 and choose my OS when I don't want the default OS.

When it is set up with only these two options, Secure Boot off and 'UEFI OS' it is fine with either OS as default, until I press F2 for BIOS or F12 for BBS.

At this point, the BIOS does a quick restart and when I get access to the BIOS, when it starts coming up again, the Boot settings have been scrambled. All the possible boot options have been enabled and put into a random order and the OS setting has been set to 'Legacy OS'.

From this point Windows will not boot as it needs to be UEFI and if I were to do any updates in Debian from this setting, the possibility exists that it might become unbootable in UEFI mode.

This looks like a bug as I can't see that the boot settings reset helps anything. The BIOS only seems stable with either Secure Boot disabled and 'Legacy OS' selected or with Secure Boot enabled and 'UEFI' selected.

This setting of Secure Boot off and 'UEFI OS' seems to be the problem and it is what I need to make my laptop work correctly.

Please could you let me know if there is something that I am doing wrong? There are so few settings, I don't see many more options to try.

Many thanks,

Dennis

Re: BIOS boot setting unstable when Secure Boot set to off andUEFI OS selected
« Reply #1 on: November 11, 2015, 07:09:09 pm »
I forgot to mention, I am using BIOS versio FD0E / F015

 

anything