Official GIGABYTE Forum

Gigabyte 990fxa-ud3 rev4.0 custom bios

regit

  • 45
  • 1
  • Donate me: https://www.paypal.me/regit66
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #75 on: April 16, 2017, 10:43:02 pm »
flashed version 8 - installed windows 10 on my samsung 960....tried to boot and....bios doesn't show the drive :D
seems it doesn't like booting from nvme

good thing now is that i have a newer bios version than my previous F3 :D

I can try add nvm if you want

BClash

  • 4
  • 0
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #76 on: April 17, 2017, 07:20:33 am »
that would be awesome :) thanksy

regit

  • 45
  • 1
  • Donate me: https://www.paypal.me/regit66
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #77 on: April 17, 2017, 12:58:54 pm »
that would be awesome :) thanksy

try this:

https://drive.google.com/open?id=0B4rC7reRUp6QLTVZdVBNRVBCZlE

Important:
The "BOOT" section of the UEFI BIOS and the shortcut to the "Bootable Devices" will not show the NVMe SSD, although it may be bootable!
After having installed the NVMe supporting OS in UEFI mode onto the PCIe/M.2 connected SSD, you will see the new bootable system drive listed as "Windows Boot Manager"
Write if work if no i will try something other.

BClash

  • 4
  • 0
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #78 on: April 17, 2017, 01:34:48 pm »
It WORKS !!!
it's so perfect. Windows 10 Installation 6 minutes 33 seconds...In BIOS i clearly can choose Windows Boot Manager on Samsung 960

Thank you sooo much !

regit

  • 45
  • 1
  • Donate me: https://www.paypal.me/regit66
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #79 on: April 17, 2017, 01:43:39 pm »
It WORKS !!!
it's so perfect. Windows 10 Installation 6 minutes 33 seconds...In BIOS i clearly can choose Windows Boot Manager on Samsung 960

Thank you sooo much !

So good.

Update v9
-add NVMe support

download
https://drive.google.com/drive/folders/0B4rC7reRUp6QeDRGRHlhWk5CdXc

regit

  • 45
  • 1
  • Donate me: https://www.paypal.me/regit66
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #80 on: April 17, 2017, 02:12:10 pm »
Ok i forget add this too:
update v10
- update EFI Realtek LAN UNDI v2.040

download:
https://drive.google.com/drive/folders/0B4rC7reRUp6QeDRGRHlhWk5CdXc

« Last Edit: April 17, 2017, 02:17:52 pm by regit »

Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #81 on: April 20, 2017, 10:49:24 pm »
Hi
I made new bios to Gigabyte 990fxa-ud3 rev4.0
i don test because dont have motherboard ,but should work fine.
You can t kill motherboard because dual bios back backup bios if something get wrong.


It f4a witch some changes :
 OROM AMD RAID MISC 4392    - 3.2.1540.6      uppdated to 3.3.1540.19)
     OROM AMD RAID MISC 4393    - 3.3.1540.17      updated to 3.3.1540.19)
     EFI AMD RAID               - 1.0.0.45      updated to 1.0.0.49)
     EFI AMD Utility            - 1.0.0.45      updated to 1.0.0.49)
     OROM Realtek Boot Agent    - 2.60         updated to 2.64)
     EFI Realtek UNDI           - 2.027         updated to 2.035)
     EFI Broadcom UNDI          - 14.0.6      updated to 17.0.5)
     OROM Broadcom Boot Agent                   (new rom 16.8.0)

I wil add vishera fix in next version, and update amd agesa .
   




https://drive.google.com/folderview?id=0B4rC7reRUp6QeDRGRHlhWk5CdXc&usp=sharingg

Thanks a lot!!!

Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #82 on: April 25, 2017, 10:29:20 pm »
Hi,
Thanks for all updates. Works perfectly.

Could you add an option like a fast boot / ultra fast boot for raid settings? (Also adding fast boot for windows boot settings idea is not bad) I have Kingston HyperX Fury ssd raid 0 array. Asrock Amd boards have a ultra fast boot mode setting in bios and raid setups as fast as intel but other manufacturers does not have this option in am3+ motherboards.

Thank you again.

regit

  • 45
  • 1
  • Donate me: https://www.paypal.me/regit66
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #83 on: April 26, 2017, 03:02:29 pm »
Hi,
Thanks for all updates. Works perfectly.

Could you add an option like a fast boot / ultra fast boot for raid settings? (Also adding fast boot for windows boot settings idea is not bad) I have Kingston HyperX Fury ssd raid 0 array. Asrock Amd boards have a ultra fast boot mode setting in bios and raid setups as fast as intel but other manufacturers does not have this option in am3+ motherboards.

Thank you again.

Hi,
 is impossible without moterboard. It will take to much time...

PTuT

  • 3
  • 0
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #84 on: May 07, 2017, 07:50:48 am »
Hello,

I am on the v10 customized/modded Bios and after I wake the computer from sleep, it works fine but sometimes I get buzzing noise that PWR_FAN (where I have hooked the water cooler's pump) has zero rpm, even though pump's LED lights blue and it seem to actually work (seems like the speed sensing on PWR_FAN is not working properly). This leads to crazy high rpm on fans and showing high temperature on CPU (based on HWInfo64). After reboot, all goes back to normal. I had this occasional problem even on F4a. Does someone else also experience this? BTW, thanks for updating the BIOS which should be done by Gigabyte and they should be sending you guys boxes of chocolate for doing their job.
Thanks.

Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #85 on: May 09, 2017, 11:56:09 am »
Hello,

I am on the v10 customized/modded Bios and after I wake the computer from sleep, it works fine but sometimes I get buzzing noise that PWR_FAN (where I have hooked the water cooler's pump) has zero rpm, even though pump's LED lights blue and it seem to actually work (seems like the speed sensing on PWR_FAN is not working properly). This leads to crazy high rpm on fans and showing high temperature on CPU (based on HWInfo64). After reboot, all goes back to normal. I had this occasional problem even on F4a. Does someone else also experience this? BTW, thanks for updating the BIOS which should be done by Gigabyte and they should be sending you guys boxes of chocolate for doing their job.
Thanks.

This has been mentioned before and is a just buggy bios the fan or temp fault causes the buzzer to sound, I seem to remember if you connect the pump to the sysfan 1 or 2 and disable the it does not have this problem.
I think it is because of bugs in the acpi implementation.

have you reset the nvram/cmos, as a mismatch in bios config can cause weird issues?

PTuT

  • 3
  • 0
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #86 on: May 11, 2017, 04:55:14 pm »
Hello,

I am on the v10 customized/modded Bios and after I wake the computer from sleep, it works fine but sometimes I get buzzing noise that PWR_FAN (where I have hooked the water cooler's pump) has zero rpm, even though pump's LED lights blue and it seem to actually work (seems like the speed sensing on PWR_FAN is not working properly). This leads to crazy high rpm on fans and showing high temperature on CPU (based on HWInfo64). After reboot, all goes back to normal. I had this occasional problem even on F4a. Does someone else also experience this? BTW, thanks for updating the BIOS which should be done by Gigabyte and they should be sending you guys boxes of chocolate for doing their job.
Thanks.

This has been mentioned before and is a just buggy bios the fan or temp fault causes the buzzer to sound, I seem to remember if you connect the pump to the sysfan 1 or 2 and disable the it does not have this problem.
I think it is because of bugs in the acpi implementation.

have you reset the nvram/cmos, as a mismatch in bios config can cause weird issues?

Thank you for your reply. Yes, I did reset the CMOS. And, it does not happen often. I could change it as mentioned but only SYS_FAN2 is non-speed controlled fan header (similar to PWR_FAN) and, I think, the cables to water pump and other fan now hooked on SYS_FAN2 may not be that long to enable swapping them. Also, I use the speed controlled fan headers for fans that can change the speed.
Again, thanks.

reeven

  • 38
  • 0
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #87 on: May 21, 2017, 09:00:54 am »
Bios seems ok as usual. Fantastic work.
We need to donate some beer to Regit.

AgentFXA

  • 313
  • 6
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #88 on: May 21, 2017, 09:19:21 am »
GA-990FXA-UD3v4.0 / FX-8320 / GV-RX570AORUS-4GD / 24GB HyperX Fury 1866  / SeaSonic 650W / Thermaltake Armor MX / Win7x64

PTuT

  • 3
  • 0
Re: Gigabyte 990fxa-ud3 rev4.0 custom bios
« Reply #89 on: June 25, 2017, 12:06:23 pm »
Hello,

I am on the v10 customized/modded Bios and after I wake the computer from sleep, it works fine but sometimes I get buzzing noise that PWR_FAN (where I have hooked the water cooler's pump) has zero rpm, even though pump's LED lights blue and it seem to actually work (seems like the speed sensing on PWR_FAN is not working properly). This leads to crazy high rpm on fans and showing high temperature on CPU (based on HWInfo64). After reboot, all goes back to normal. I had this occasional problem even on F4a. Does someone else also experience this? BTW, thanks for updating the BIOS which should be done by Gigabyte and they should be sending you guys boxes of chocolate for doing their job.
Thanks.

This has been mentioned before and is a just buggy bios the fan or temp fault causes the buzzer to sound, I seem to remember if you connect the pump to the sysfan 1 or 2 and disable the it does not have this problem.
I think it is because of bugs in the acpi implementation.

have you reset the nvram/cmos, as a mismatch in bios config can cause weird issues?

UPDATE: I did finally got extending fan cable and swapped the pump and system fan and it seems solved the issue. Thx.